Pauly C


We recently upgraded client to latest version of app that was also upgraded to VFP 9. Our client runs app in Citrix environment and we are seeing strange behaviors that at times data doesnĄ¯t get stored to the SQL Server 2000 backend, IĄ¯ve been able to prove this by creating and setting up auditing on SQL Server. At times itĄ¯s a segment of data at other times an entire row of data is lost. All of data is stored in vfp views and updated with tableupdate(.t.,.t.,[view name]). We cannot duplicate this in house and IĄ¯m starting to wonder if it can be the Citrix environment that is causing this problem. Our clients also complains that the application has started to move slower after the update and now when they open the app via Citrix at times the forms are blank until the client sets focus to a control forcing a page refresh. Any ideas





Re: Data not getting written to SQL.

AndyKr


You really haven't provided much information here and, for future reference may I recommend that you post only one question per message - it makes it easier for people to understand and easier for you to track your answers....

[1] The usual cause of data being mysteriously not written is that the TableUpdate is failing. You MUST check the result of TableUpdate() calls - especially for remote views because a failure does not throw an error. The code to do this is simple:

IF NOT TableUpdate( .T., .T., 'remote_viewname' )
AERRROR( laErr )
MESSAGEBOX( laErr[2] )
ENDIF

[2] Forms not showing until a refresh is forced sounds like a LockScreen is being left in place when the form is initialized but without more information it is hard to guess....







Re: Data not getting written to SQL.

Pauly C

The only question I was asking was if anybody else was experiencing the same type of strange behavior with data not getting writing to the backend with the tableupdate. I only included the information about the application is running slower as general information and to see if could be some type of time out issue. Also I was trying to be as general as possible because IĄ¯m not entirely sure what is going on and I canĄ¯t seem to debug.

We do check tableupdate for success or failure, on success it commits the transaction otherwise it does a rollback and displays an error. They do not get an error message but the data still doesnĄ¯t get written to the backend, they ran for years without problems before the latest upgrade that included VFP9 which makes me wonder if that could be the issue.







Re: Data not getting written to SQL.

AndyKr

I am sorry, I misunderstood you.

As far as I am aware there were no changes in VFP 9.0 that would affect SQL Server updates - if there is a change it is probably in your configuration (the transaction setting on the connection for example).






Re: Data not getting written to SQL.

Pauly C

Ok, as you can tell I'm really reaching to try and find out what is going on. I appreciate your help.

Thank you,

Pauly C