pushkar1210


The customised software application developed in Visual Foxpro 6.0. Can we run the same customised software in Visual Foxpro 9.0 without making any changes in software

Visual Foxpro 9.0 supports all application software developed in Visual Foxpro 6.0

Regards,

Pushkar Mantri.





Re: Visual foxpro 6.0 compatible to visual foxpro 9

Markish


Hi Pushkar,

VFP has been always downward compatible. Applications in VFP 6.0 can run on VFP 9.0 with no modifications or very less modifications. You have to pay little attention to the SQL which involves group by clause. VFP 9.0 is more ANSI 92 Compliant. You may also set reportbehaviour to 80 for Backward compatibility.

Best regards,

Markish







Re: Visual foxpro 6.0 compatible to visual foxpro 9

Alex Feldstein

It should compile fine with no changes or maybe minor ones depending on your coding. The most important change you may get a warning about has to do with the way aggregates are written in SQL queries.

There was a subtle bug in VFP 6 in that it allowed for some non-ANSI compliant SQL queries. In short you have to provide every non-aggregate column when using aggregates and gGROUP BY. It is all documented in help and online. Beware of the SET ENGINEBEHAVIOR command fior backward compatibility as it does not fix the problem but masks it, therefore allowing for potential erroneous results.

Menus now allow a few more features like images. If you change a menu, it is not easy to revert it to go back to VFP 6. If you do not plan to go back then your are OK.

Table structures have some changes. If you use newer constructs (e.g. AutoInc columns), you cannot go back.

There are many, many enhancements, most notably in the report writer. Go for VFP 9. You will like the improvements!






Re: Visual foxpro 6.0 compatible to visual foxpro 9

dni

It will be some light errors, and you will have a error list after compilation. You may check (for versions concordance) :

http://k7waterfront.org/wc.dll Wiki%7EVFPVersionPropertyConcordance%7EVFP






Re: Visual foxpro 6.0 compatible to visual foxpro 9


Re: Visual foxpro 6.0 compatible to visual foxpro 9

dni

I just click on link and it is working....






Re: Visual foxpro 6.0 compatible to visual foxpro 9

Alex Feldstein

Steve was advised of the problem. He decided to do a fix by redirecting it to the proper Wiki so as not to break the link you used here. If you try it now, you will see that it redirects to the Fox Wiki. Thanks for uncovering the problem.



Re: Visual foxpro 6.0 compatible to visual foxpro 9

mathmo

Is this not almost exactly the same question as in another thread
http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=2091318&SiteID=1

Not too suprising to see questions repeated.... this happens a lot, but this is a thread posted only earlier this week!

Anyway.... check out the other thread, you will see more info there saying the same sort of stuff.