xuyca


I have same vfp application program. But I found that it run much slower than previous version when loading a form in vfp9 compiled application. Anybody have same problem




Re: VFP9 applications running much slower than VFP6 and VFP8

Aleniko


Try setting Enginebehavior 80 and see if this helps.

Also, is it just loading the form or something in the load events that slows down





Re: VFP9 applications running much slower than VFP6 and VFP8

Carl Warner

Just for speed test purposes, SET TABLEVALIDATE TO 0 (default is 3) and see if your speeds pick up. I have seen others having issues with speed due to the TABLEVALIDATE setting, even via the OLE DB Provider for VFP.




Re: VFP9 applications running much slower than VFP6 and VFP8

xuyca

At the first time loading form is slow and second time is fast. Close the form and loading the form again, it change slow again. I don't know why It never happen in VFP6 and VFP8 before. Same program and same computer.





Re: VFP9 applications running much slower than VFP6 and VFP8

xuyca

I set SET TABLEVALIDATE TO 0. It is still same slow. Nothing change. Only loading the form.





Re: VFP9 applications running much slower than VFP6 and VFP8

Carl Warner

How is the data being loaded into the controls on the form

Are there a lot of controls on the form that are being instantiated as it loads

We can't see your form on our end and we can only guess.





Re: VFP9 applications running much slower than VFP6 and VFP8

Tamar E. Granor

Are you using any collation sequences other than the default If so, make sure to SET COLLATE to the same sequence you're using.

Tamar