Bronxgodzilla


Hi there... I'm just trying to solve this little annoying Gotcha & would appreciate help from experienced problem solvers. Old V6 code creating my data input windows, now blanks when I bring my mouse across it, then have to "hunt in the dark" for event buttons (Add, Goto, Exit, etc) which then appear when mouse is over them. Then only about half the window appears. Truly weird. Really simple x-base style code in the begining, after a number of db are opened, windows, popups, indexes being defined. Also declaring a few dozen vars. Is there some special V9 var I should be declaring to prevent or augment something Jeez.

Would be a bummer and dangerous to start re-coding the app. Have switched to visual9 due to poor memory performance of my original V6 exe on xpro, vista. Any help Havent used the debugger yet, dont think that will do much but give me same phenomena in slow motion :-)

Thanks much

Barry





Re: Upgrading V6 app to V9 gives strange Windows Phenomena

Markish


Hi Barry,

You can try setting the 'themes' property to false. Something like

Code Block

Thisform.themes=.f. && For Form Level

_screen.themes=.f. && For Screen Level

Hope this helps..

Best regards,

Markish







Re: Upgrading V6 app to V9 gives strange Windows Phenomena

Bronxgodzilla

Egg-cellent, Markish! the _screen.themes=.f. worked perfectly. the Thisform.themes=.f. will be inserted elsewhere. Would like to know why this worked :-)

Again, thanks for quick response. Impressive!

Barry







Re: Upgrading V6 app to V9 gives strange Windows Phenomena

Markish

Hi Barry,

Welcome....

'When Themes is enabled, Visual FoxPro overrides the SpecialEffect property and uses the default theme except when SpecialEffect is set to a value of 2 (hot tracking). ....."

Please refer the Doc. http://msdn2.microsoft.com/en-US/library/aa977016(VS.71).aspx for detailed explaination.

Best regards,

Markish