TRJ48


I have developed a form in VFP 8 which has multiple grids on it. It runs fine from VFP but when I run it from the EXE it gives the following error when trying to load the form. Error Loading File - Record Number 66. ResoGrd <or one of its members>. Parent : Not a Table. I checked the parent field in the .SCX and it looked fine - it just had the form name. I tried deleteing all of the objcode and recompiling the form, but still get the error. I also tried deleting the offending grid, saving the form, and then pasting the grid back in. Still get the error.

Thoughts anyone I am under a tight deadline and this is definitely a show stopper.

Thanks,

Tom




Re: VFP 8 Form Issue

dni


On what computer do you have the error in exe file On computer with vfp installed or a computer with vfp runtime files only







Re: VFP 8 Form Issue

TRJ48

I am running it on the same computer. I also tried creating a new form and pasted all of the controls onto it, but had the same result. Do you have any idea what it means that the parent is not a table I had thought the parent was the form the control is on. Of course, this may be one of those error messages that mean something other than what they say.

Thanks






Re: VFP 8 Form Issue

dni

I had once the same error like you in exe file but ran from a computer without vfp installed. I solved problem coping a vcx file in application folder. It was from a control placed on a form who need it.






Re: VFP 8 Form Issue

MarciaAkins

TRJ48 wrote:

I have developed a form in VFP 8 which has multiple grids on it. It runs fine from VFP but when I run it from the EXE it gives the following error when trying to load the form. Error Loading File - Record Number 66. ResoGrd <or one of its members>. Parent : Not a Table.

Just a SWAG here - is the grid class that is causing the problem using member classes






Re: VFP 8 Form Issue

Naomi Nosonovsky

Does the form work without grid in question May be you can add it in run-time instead since something is omiss with this grid.





Re: VFP 8 Form Issue

TRJ48

The form runs fine without the grids. Each of the grids has, at least, one combo list. If I remove the combo lists, the grids work fine.

Thanks,





Re: VFP 8 Form Issue

Naomi Nosonovsky

So this is the problem. Remove the combo from the grid and try to add it in run-time instead.




Re: VFP 8 Form Issue

TRJ48

Well, I have resolved the problem, but I still don't know the real cause. I switched to a different gris class and a different combo box class and that corrected the issue. I still suspect that the Parent: Not a class message is not really the problem but was the closest the system couls come up with.

Thanks for all of the suggestions!

Tom