tarikelmallah

Dears,

my [Site Actions] not display all items, as manage content, and edit page and create site and...

and there is error say that Object reference not set to an instance of an object.

this is link to photo print screen of my problem :
http://www1.uploadhut.com/viewimage.php type=2&id=11847-sharepoint.JPG

when i see the event log, i found error say that:

Event Type: Error
Event Source: Office SharePoint Server
Event Category: Publishing
Event ID: 5169
Date: 9/6/2007
Time: 9:42:58 PM
User: N/A
Computer: TAREK-MOHAMED
Description:
Console Configuration File Error: XML Exception: Object reference not set to an instance of an object.

i diactivate and reactivate the features, but the same result....

note that, site was working good before,

any one can help please..




Re: SharePoint - General Question and Answers and Discussion Site Actions not display all items

kwm

Hey Terek,

Did you deactivate on site collection level and did you do an iisreset before reactivating the feature





Re: SharePoint - General Question and Answers and Discussion Site Actions not display all items

tarikelmallah

thanks kwm ,

yes i deactivate on site collection level and i make iisreset before reactivating the feature, but same result,

but there is a note in deactivating on site collection level when i try to deactivate an error raised after deactivate done as:

Object reference not set to an instance of an object. at Microsoft.SharePoint.SPFeatureCollection.FeatureHasActiveDependants(Guid featidDependee)
at Microsoft.SharePoint.SPFeatureCollection.DeactivateHiddenFeatureDependencies(Guid featidDependant, Boolean fForce)
at Microsoft.SharePoint.SPFeatureCollection.Remove(Guid featureId, Boolean force)
at Microsoft.SharePoint.SPFeatureCollection.Remove(Guid featureId)
at Microsoft.SharePoint.ApplicationPages.DeactivateFeaturePage.LnkbtnDeactivateFeature_Click(Object objSender, EventArgs evtargs)
at System.Web.UI.WebControls.LinkButton.OnClick(EventArgs e)
at System.Web.UI.WebControls.LinkButton.RaisePostBackEvent(String eventArgument)
at System.Web.UI.WebControls.LinkButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Troubleshoot issues with Windows SharePoint Services.

But reactivate done.






Re: SharePoint - General Question and Answers and Discussion Site Actions not display all items

tarikelmallah

i found the solution

it's Missing Feature install in MOSS but not found,

we found the Missing Feature by the help of small program "MissingFeature.exe" http://www.mediafire.com/ 8tet014djlr

then uninstall this feature by command line

then deactivate all site features

then reset IIS

then activate all site features again

then iisreset

then it's work

thanks all..