jilted

Please help, trying to install WSS 3.0 on a x64 W2K3-server that is running WSS 2.0, but i get an error at the beginning of the setup:

"This product requires ASP.NET v2.0 to be set to 'Allow' in the list of IIS Web Server Extensions"

I have verified that it is set to allow, so that is not the issue.



Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Douglas Lorenz

I am having the exact same problem... I am also running the x64 version of Windows Server 2003. To take it a step further, when I try to run the SharePoint 3.0 installer, I get the following error language:

Setup is unable to proceed due to the following error(s):
This product requires ASP.NET v2.0 to be set to 'Allow' in the list of Internet Information Services (IIS) Web Server Extensions. If it is not available in the list, reinstall ASP.Net v2.0.
Correct the issue(s) listed above and re-run setup.


When I first tried to install it, I got an additional error stating that I needed .NET 3.0. I installed that, and that part of the error message no longer appears.

It states in my IIS Web Service Extensions page that "ASP.NET v2.0.50727 (32-bit)" is listed as "Allowed". I do not know how to uninstall ASP.NET and reinstall it






Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

jilted

I have registered this as a support case with microsoft, waiting for them to call me during the day. Must be a problem with the x64-platform, a google-search shows very little info on this error message...



Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Douglas Lorenz

One of the many x64 problems... They really should have some people dedicated to dealing with x64 compatibility issues...

If you get a workable response, please pass it back this way. I'd like to be able to use SharePoint...




Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

jilted

Hi!

MS support had no quick solution but i got it working by myself. I uninstalled IIS, reinstalled IIS, repaired ASP.NET (dotnetfx3_x64.exe) and then i could change the ASP.NET v2.0 IIS WSE from 'prohibited' to 'allowed'.
After that, WSS setup went just fine!





Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

visualechodesigns

super.



Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

UkonCornelias

This isn't just a 64 bit problem. I had the same problem on a 32 bit Win2003 server. Even though I had .net 1.x, 2.x and 3.x installed, IIS only recognized ASP.net 1.x. It might have something to do with installing IIS after you install .net 2.0, which is what I did.

Since I had already installed .net 3.0 (a requirement of Sharepoint Services 3.0), I uninstalled .net 3.0, uninstalled .net 2.0, then reinstalled .net 2.0 and reinstalled .net 3.0. I then opened IIS and sure enough, ASP.net 2.0 was listed. I changed it to allow, and Sharepoint installed OK.

Sounds like a bug to me...





Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Ga-De

Try running aspnet_regiis -i at .NET 2.0 folder under \WINDOWS\Microsoft.NET\Framework\. ASP.NET 2.0 shows up in IIS after I run the command.



Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Douglas Lorenz

I faced an additional problem... I had IIS running in 32 bit mode, which was necessary for some database compatibility. Because I was running an x64 operating system, it wouldn't let me install the 32 bit version of SharePoint, and it wouldn't let me run the 64 bit version of SharePoint while ASP.Net was in 32 bit mode.

So I am stuck. I can either run SharePoint in 64 bit mode and not be able to run the website functions which require 32 bit ASP.Net, or vice-versa...

I really hate the x64 version of Server 2003. It's been nothing but problems.




Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

professzor1

"Try running aspnet_regiis -i at .NET 2.0 folder under \WINDOWS\Microsoft.NET\Framework\. ASP.NET 2.0 shows up in IIS after I run the command.
"

 

Worked! Thx.





Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

VlasVargo

FYI,

If you still get the error after running through the above on an x64-bit machine, please run

C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727\aspnet_regiis.exe -i

Note the (Framework64) folder instead of just (framework).

I was getting this error even after running all of the above until I did what I stated above. Now it gets past the error.





Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Anonymous

It works. Thanks



Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Dana JC Orosz

Running the posted command does fix the ASP.NET error for installing SharePoint Services 3.0 under Windows 2003 Server (all versions). Many thanks to Ga-De for posting this. I did not have to return to the IIS console to enable this "Allow" permission either.

However, the path is currently:

\\Windows\Microsoft.Net\Framework\v2.0.50727

And the command itself is:

aspnet_regiis.exe -i





Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

Hwest

An easy fix to this problem is to simply register ASP.NET 2.0 with the command: aspnet_regiis -c then select allow under the registered services in IIS.

Hal.

NET Framework Tools

ASP.NET IIS Registration Tool (Aspnet_regiis.exe)

When multiple versions of the .NET Framework are executing side-by-side on a single computer, the ASP.NET ISAPI version mapped to an ASP.NET application determines which version of the common language runtime (CLR) is used for the application. The ASP.NET IIS Registration Tool (Aspnet_regiis.exe) allows an administrator or installation program to easily update the script maps for an ASP.NET application to point to the ASP.NET ISAPI version that is associated with the tool. The tool can also be used to display the status of all installed versions of ASP. NET, register the ASP.NET version that is coupled with the tool, create client-script directories, and perform other configuration operations.

Note

There are two IIS Registration Tools that ship with the .NET Framework; one for standard systems and one for 64-bit system. The tool for 64-bit systems in located in the Framework64 directory of the Microsoft.NET directory inside the Windows folder; for example C:\WINDOWS\Microsoft.NET\Framework64\v2.0.50727 would contain the IIS Registration Tool.

aspnet_regiis [options]




Re: SharePoint - Setup, Upgrade, Administration and Operation Setup Error: This product requires ASP.NET v2.0

chris888

"I had IIS running in 32 bit mode, which was necessary for some database compatibility. Because I was running an x64 operating system, it wouldn't let me install the 32 bit version of SharePoint, and it wouldn't let me run the 64 bit version of SharePoint while ASP.Net was in 32 bit mode."

I have exactly the same problem. I am not able to install WSS 3.0 in 32-Bit mode on a x64 Windows Server with SP2. Is there any solution right now