SukhiNew

I have installed Sharepoint 2007 (advanced), with Sql server 2005 on separate server. Upon completion when go to Central Administration, I get 'Server Farm Configuration Not Complete' on top left corner, click on Admin tasks, get the following:-

Administrator Tasks

1 READ FIRST - Click this link for deployment instructions Not Started
1 Initial deployment: Add servers to farm Not Started
1 Initial deployment: Assign services to servers Not Started
1 Configure server farm's shared services Not Started

Farm Topology
Server Services Running
BACSPS02 Central Administration
Windows SharePoint Services Help Search
Windows SharePoint Services Incoming E-Mail
Windows SharePoint Services Web Application

BACSQL03 Windows SharePoint Services Database

When I try to start 'Windows SharePoint Services Help Search ' it will not start with the same account which I used to install sharepoint, I had to used different one(is that right ).

Now, when I try to create new SSP, I create new web application (Sharepoint - 80), but it comes with the error 'no indexers', but there is no index server to choose from.

Sorry about the long question, been at it for days, just found this forum. Thanks




Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

Gary A. Bushey

Make sure the Office SharePoint Server Search service is running as well




Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

Ishai Sagi

with at least the indexing role activated (the search service can have either one or two roles - indexer and search)




Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

MarcMath

So i cannot use the front-end webserver as an indexing server This is what i conclude from your reaction. I am facing the same problem, and i'd like to figure out what the cause (and the solution) is. There also is no Office SharePoint Server Search service available on the server.

The way i see it, the problem could be in :

- the difference between the standard and enterprise edition of SharePoint.
- installation type (front-end, single server)

If someone could give me the answer, i'd be very happy! :)





Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

kiral

No, you can have indexing service on the front-end machine. This is actually the only option for a small farm (WFE + SQL).

I would make sure that MOSS is installed using the Complete option in its setup. If you choose WFE, the setup just won't install application services (such as Search) on the box.

Hope this helps,






Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

MarcMath

Thanks for your quick response.

Sounds a bit odd to me why it can't be done, but there probably will be a good explanation to it. Would you perhaps know if you still can connect sharepoint to another SQL server. The reason i selected WFE was because i could use another back-end SQL server.

Greets marc





Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

kiral

You can use a remote SQL back-end in either cases (WFE and Complete). The difference between them are services installed by the setup on the server. In case of WFE, only the Windows SharePoint Web Application service is installed, allowing the server to be a front-end web server in the farm. If you want application services (Search, Excel Services etc.), you MUST deploy with the Complete option.




Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

MarcMath

Great! Thanks for the explanation, somehow i think the installer lacks in providing this information, but the problem may also exist between keyboard and chair ;)






Re: SharePoint - Setup, Upgrade, Administration and Operation No Please Help-Server Farm Configuration Not Complete

lanchick

OMG !!! I was having the same problem !!!

I am SOOO glad I finally found someone else that was having the same issue !

I WAS PULLING MY HAIR OUT !!!

Now that I have this resolved I can be on my way to learn the in's and out's of the new SP2007 stuff !

THANKS