Toni Tunkkari

Hello,

Two of our MOSS users found strange problem when they tried to open or edit document in document library. When they try to open document menu, IE gives error:

Internet Explorer Script Error

Line: 578

Char: 1

Error: Object expected

Code: 0

URL: http://<servername>/<sitecollection>/<site>/<documentlibrary>/AllItems.aspx

Do you want to continue running scripts on this page

Yes / No

Can anyone help me what to do Users cannot do anything with documents now.

Best Regards

Toni



Re: SharePoint - General Question and Answers and Discussion Script error when opening document menu

JungleAnt

Is it only two users that get this problem while the rest are fine

If so they it has to be a problem at their end. I would start by working out what differences there is between these two users and every one else. Operating System, Office Version, IE version (does it work if Firefox on their machine), do they still get the same error logged into another machine

If you rule out the machine environment as being the problem then I'd look at how they are set up as users. Permissions etc.

Failing that then have a look at the server where MOSS is installed and see if you can see any errors in the logs. This might help narrow the search down.

I suspect that it will be on their environment. A good place to start is installing updates to see if this resolves the issue.

Also what happens if they click "yes" to run the script. Does it function normally or does it crash

Post back if you find out what the problem was.




Re: SharePoint - General Question and Answers and Discussion Script error when opening document menu

Toni Tunkkari

JungleAnt wrote:
Is it only two users that get this problem while the rest are fine

If so they it has to be a problem at their end. I would start by working out what differences there is between these two users and every one else. Operating System, Office Version, IE version (does it work if Firefox on their machine), do they still get the same error logged into another machine

If you rule out the machine environment as being the problem then I'd look at how they are set up as users. Permissions etc.

Failing that then have a look at the server where MOSS is installed and see if you can see any errors in the logs. This might help narrow the search down.

I suspect that it will be on their environment. A good place to start is installing updates to see if this resolves the issue.

Also what happens if they click "yes" to run the script. Does it function normally or does it crash

Post back if you find out what the problem was.

Hi,

Those two users has same environment as we have. Only difference is that they use MOSS from different country and different DNS area. IE is same as I have also Office version. We don't recommend to use Firefox because we are large company and we want all users to have same environment. Those users has Contributor permissions so I believe that they have enough permissions to use site and document libraries.

I haven't found any error messages in MOSS Front End so I believe that problem is in client side.

I don't know what happens if they click yes. I have to ask.

Best Regards

Toni





Re: SharePoint - General Question and Answers and Discussion Script error when opening document menu

L.Kentill

Hi,

Can anyone help me out on this issue :

While trying to open a Excel file via a shared document library on Sharepoint - Internet Explorer locks up and dumb all other open windows (within IE). This issue not only relates to Excel 2007, but repeat it self with PP 2007, Word 2007....

I'm able to open a document first time, but while opening another document in same or other document library - then IE locking & dumb......(pardon my french - but is p..... me off).

Data: I have recently installed Office 2007 and I'm using company based Sharepoint Portal Server 2003. Internet Explorer version is v7.

I have searched overall over the "place" to find a solution but have failed......

Yours, Lars





Re: SharePoint - General Question and Answers and Discussion Script error when opening document menu

Anonymous

I have the same problem as Toni described. I cannot edit MOSS menu because my computer is refusing to display MOSS document menu. There are no menu items in the menu pane on Navigation page. I use WV Business with IE7. Reinstallation of vista did not help. The problem started suddenly about three days ago. Before this everything was OK. Other computers in our company are able to edit menu normally, no matter if they are running vista or xp.

My computer also throws message Error by loading DDL Library every time I browse any MOSS Page. Dump from debugger (part of script init.js, the break point is bold) is this:

}
bIMNControlInited=true;
if (IMNControlObj)
{
IMNControlObj.OnStatusChange=IMNOnStatusChange;
}
}
return IMNControlObj;
}
function IMNImageInfo()
{
this.img=null;
this.alt='';
}

Can anyone help me to resolve this problem

Pavel





Re: SharePoint - General Question and Answers and Discussion Script error when opening document menu

Anonymous

PROBLEM RESOLVED!

I used the diagnostics tool for MS Office in Sharepoint Designer 2007 Help section. Running the tool resolved the problem.

Pavel