Andrew Crowder

I created a KPI list and added a new Indicator using data in SharePoint List. The indicator uses information from a Tasks list on a different site within the same site collection. The indicator appears correctly in the KPI list, however, when I click on the indicators name I get the following error message:

Incorrect function. (Exception from HRESULT: 0x80070001)

If I create the exact same type of indicator with all the same values but for a tasks list on the same site as my KPI list it works fine.

Anyone seen this before Can I not pull indicators from multiple SharePoint sites

Thanks,

Andrew



Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

TheRich

hi,

I get the same error when I try to use a KPI for a MOSS 2007 - site template:

when I add a kpi to a site whose data source is a list inside the same site, save the site as an sitetemplate and create a new site from that sitetemplate, the kpi on that new site is still linked to the origin site (from which I created the sitetemplate). Omho thats a bug in the current release of sharepoint server 2007. The kpi is the only element of an site template (my experienence) whose datasource will not be mapped to the new created site.

I think the reason is the changing of the site relative path to an absolute server path at the moment when you define a list as datasource for the KPI.

Its a horror to me and my plan to create rich site templates!

Maybe some handwork with the sharepoint designer or visual studio cuts that gap.

Richard





Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

andrew woodward

I have also seen this error, however I am sure you can view it by using the drop-down menu and selecting view option, small bug in the current release.

Andrew






Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

Andrew Crowder

I get the same error whether I click on the name, or use the view properties menu item. I tried to open a case with MS TCS and the first person I spoke with was very helpful. He did several hours of research and when he couldn't find anything helped me set up a case with the SharePoint Engineering team. I got one call from them where we went over the same information I gave to the person in TCS and that was the last I ever heard from them. I tried calling and e-mailing my POC several times over the course of two weeks and finally gave up.

I figured out we could probably do this using excel services and that would be easier to implement anyway.

Andrew





Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

Greg Siefert

I'm having the same problem with the absolute path. I'm looking at creating a site feature (to run when a site is created) and stapling it to the site template. The feature would simply update my KPI list to the newly created site. I hope that this helps as a workaround for now!




Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

Andyoye

Any solution for this error
thanks




Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

Andrew Crowder

I never found an answer to this but I didn't keep looking. I was hoping it would be fixed in SP1 when that is released.

Andrew





Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

WSS- Workflow

Hi,

I m having similar error while creating a KPI list with a new indicator using xml file from a task list on a site which is a subsite of the prior one in which the KPI list has been created, however i m not finding the option itself to create a KPI list under the subsite. I hv not tried this with the same site.

Error is exactly same wht Andrew has quoted.

Anyone please suggest the solution.

Thanks,






Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

PatnaikILU

I'm having the same issue as Andrew has mentioned above, I have installed WSS 3.0 SP1, but that did not help.

Andrew, did you get solution for this

Thanks,

-Sanjay





Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

Andrew Crowder

Sanjay,

I never did find a solution to this but I did not peruse it as we deemed we did not need the feature on the project and then the project ended. ItĄŻs too bad SP1 did not fix it though.

Andrew





Re: SharePoint - Business Intelligence KPI List - Error with KPI different Site

John D. Ross

The issue isn't really a bug at all. I don't have have my VM open at the moment so forgive me if this isn't 100% -- but the problem occurs when you don't provide a link for the item in the KPI List. If you go to one of the items in the KPI List and edit it, there will be a collapsed section called Link Details (or something similar -- it is the first collapsed section) and add the link to the view where you'd want users to go who click on the project name. That will resolve the issue. At least it did for me.

John

http://www.sharepointblogs.com/rossonmoss