John Galt 2007

I am following the instructions for migration MS TFS from WSS 2.0 to WSS 3.0:

http://msdn2.microsoft.com/en-us/teamsystem/bb676233.aspx

Part of this procedure requires creating a new WSS 3.0 web application using Sharepoint Central Services, backing up the WSS 2.0 content database and restoring it to WSS 3.0.

At step 10, this database is to be added using the following command:

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsadm -o addcontentdb -url http://athena:81 -databasename WSS_Content_TFS

Which generates the followng error:

WSS_Content_TFS on Athena contains user-defined schema. Databases must be empty before they can be used. Delete all of the tables, stored procedures and other objects or use a different database.

Sooooo... what do I do NOW I appear to be dead in the water.



Re: SharePoint - General Question and Answers and Discussion stsadm -o addcontentdb not working as expected

kwm

Hi there,

This error normally appears when SharePoint detects a database with the same name as the one it is trying to create.

What is the name of the content db you created with the new web application If it is the same as the one you at trying to add then you found your problem.





Re: SharePoint - General Question and Answers and Discussion stsadm -o addcontentdb not working as expected

BillyM 2005

Thank you for your post. I actually found the problem (much to my embarassement). I stopped the sharepoint content db but, unfortunately, mistakenly backed up and restored the CONFIG db. Backing up and restoring the content db solved this problem.