Palmi

Hi, I have a problem, I am making a document view in an asp.net website, everything is working fine in Visual studio but when I try to use it in IIS on the same machine as the SPS I get an error

Message: The Web application at URL could not be found. Verify that you have typed the URL correctly. If the URL should be serving existing content, the system administrator may need to add a new request URL mapping to the intended application.
Trace: at Microsoft.SharePoint.SPSite..ctor(SPFarm farm, Uri requestUri, Boolean contextSite, SPUserToken userToken)
at Microsoft.SharePoint.SPSite..ctor(String requestUrl)
at TasksEdit.ASPxGrid1_BeforeDeleteCommand(Object source, BeforeDeleteCommandEventArgs e) in c:\Inetpub\wwwroot\Dams\TasksEdit.aspx.cs:line 434
at DevExpress.Web.ASPxGrid.ASPxGrid.OnBeforeDeleteCommand(BeforeDeleteCommandEventArgs& e)
at DevExpress.Web.ASPxGrid.ASPxGrid.DataCtrlr_BeforeDeleteRow(DataControllerRow dataControllerRow)
at DevExpress.Web.ASPxDataControls.ASPxWebDataControl.DevExpress.Web.ASPxDataControls.IDataControllerListener.BeforeDeleteRow(DataControllerRow row)
at DevExpress.Web.ASPxDataControls.ASPxDataController.ListenersBeforeDeleteRow(DataControllerRow row)
at DevExpress.Web.ASPxDataControls.ASPxDataController.DeleteRow(DataControllerRow row)
at DevExpress.Web.ASPxGrid.ASPxGrid.DeleteRow(Row row)
at DevExpress.Web.ASPxGrid.ASPxGrid.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument)
at System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData)
at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Can anybody help, pleas




Re: SharePoint - Development and Programming SPsite url not working in asp.net website

Ishai Sagi

I had that issue and found that the two sites need to work on the same application pool for the sharepoint code to work. try it.

Ishai Sagi
www.spstips.blogspot.com






Re: SharePoint - Development and Programming SPsite url not working in asp.net website

Palmi

Hi

Thanks so much.

That worked fine. But now I can only connect to my web application from the server not from my client.

Do I need to setup security for the client user






Re: SharePoint - Development and Programming SPsite url not working in asp.net website

Ishai Sagi

do you mean you can only browse to the site from the server why what happens when you browse from the client




Re: SharePoint - Development and Programming SPsite url not working in asp.net website

Palmi

Yes, login appears and I caní»t login.






Re: SharePoint - Development and Programming SPsite url not working in asp.net website

Palmi

Is it maybe better to make a custom Web Service