Ludovic Chungue

Hi all !

With great pain I have successfully configured MOSS for a multi-provider authentification using 2 Web Applications (one extending the other). So now I have one "internal" access using Windows authentification and one "external" access using FBA&AD.

However I have noticed something : whenever I login using the "external" access, the MySite link vanishes...
So is there a config somewhere that I'm missing is it even possible to access MySite through an extended Web App

Thanks in advance for your help !

Ludovic



Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

lchungue

To make it short : is it possible to display MySite links (on Welcome page) while using an extended Web App





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

Charbel CHARBEL

Hi,

Yes of course you can do that. You can add a content editor web part on your page and insert a hyperlink in it to make it point to "_layouts/mysite.aspx". It will redirect you to the mysite page.

You can also use the same control for MySite that is available in the default sharepoint page.





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

lchungue

Alright thanks !
Actually I just thought there was a hidden option somewhere, because both intranet and extranet seemed to share the same page and layout ; and somehow, extranet didn't display that link by default... But if I have to edit the page, then be it. Smile





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

The Brebinator

Hi there,

Did you have any group issues at all EG: Creating a group in AD and adding users to that group and FBA working for those new members

Brebo





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

lchungue

Hi sorry for the delay, I've lost track of this thread...

Yes I do have group issues ! This is somewhat surprising you mention this, because this is actually one of my main concerns recently... Is there any relation between multi-providers and group issues I'm encountering

For your information, added users from AD seem to be detected correctly.

By the way, I have finally make the multi-provider work along with MySites for everyone. Unlike mentionned above, simply adding a link to the MySite page didn't work... I had to place the MySiteHost under SharePoint-80, extend SSP for 2nd provider and from there, grant users permission.






Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

The Brebinator

Hi there,

Well that has been my main issue with FBA for AD. in that I cant work out how I can control users from within an AD Group that is used directly in MOSS.

I would like to use AD as my single control point... any help in this space would be great...

IVan





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

lchungue

I've got words that there could be some issues using Standalone configuration. Any chance this might be the problem





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

The Brebinator

Hi everyone,

The installation that I have whereby they require FBA is not a basic installation but a separate SQL and WFE so all elements can be extended.

So I guess this negates this other than the fact that it all is still on 1 logical server...

Brebo







Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

lchungue

Aww... does it mean this comes from FBA/AD then
Would be surprising we are the only ones experimenting this problem though...





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

The Brebinator

that is exaclty what I thought. Surely there are others that have the same issue.

FBA all managed by AD (Roles /Groups / Users)

Brebo

I think we will be talking about this for a while. Smile





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

lchungue

I guess so... provided this thread doesn't die too soon

Well, another question relevant to FBA/AD : don't you have any problem with "synchronizing" your FBA accounts with your User Profiles
My User Profiles are like "domain\user", because I'm directly hitting AD.
But when logged in with my FBA accounts, it's more like "membershipprovider:user"...

Any clue to this

By the way, I'm thinking of changing the title of this thread if you don't mind... hoping it'll get more readers.





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

The Brebinator

Go for it...

Oh sorry I have been off the FBA case for a bit.. just working on other stuff. But I am back here now trying to get it going.. Smile.





Re: SharePoint - General Question and Answers and Discussion [MOSS2007] MySite for "Extranet" (multi-provider)

Ludovic Chungue

Nice. Please let me know if you find anything then Wink