bszom

I am using the Page Viewer web part to display a seperately hosted ASP .NET site on one of my SharePoint pages.
Initially the external site is displayed fine and contained within the SP page. If I start navigating on the external site, after a couple of clicks the SP borders, navigation and layout disappear and it looks as though I had accessed it directly through my browser rather than through SP.

Is this by design As far as I understood, external sites accessed through the Page Viewer web part were always supposed to remain contained within the SP site/page This is happening in IE/FF. The internal links on the ASP .NET site are all relative (~/path/path/something.aspx), so I don't understand what could be causing this...

Does anyone have any ideas


Re: SharePoint - Design and Customization Page Viewer web part problem - leaves SharePoint site???

rick postmus

I had a simular problem myself and i use a iframe instead now. I made a contentquerywebpart and made a simple iframe and now everything works fine.

Greetz




Re: SharePoint - Design and Customization Page Viewer web part problem - leaves SharePoint site???

bszom

SharePoint allows the inclusion of external sites in a Web Part called the Page Viewer Web Part. The Page Viewer Web Part stores a URL. When the page is rendered, the server accesses the Web page at the URL and includes the response inside the Web Part. (For the more technical readers, the requested page is displayed in an IFRAME tag.)

A
pparently that is exactly what the Page Viewer web part does... how does your custom web part differ, if you don't mind me asking

Thanks!