Averied

Hi, today morning when I arrived work and try to access my sharepoint portal, I get the error "cannot connect to configuration database" .. for my surprise, I chek SQL server, and the "Sharepoint_Config" database is missing. I have no backups, and the only thing I have left is the content database "wss_content_SOMETHING" ... And I also have the "Inetpub" localfolder..

So my question is if is there anyway to recover my site with this data I have left.. Maybe creating a new configuration or new site and adding WSS_Content..

The thing is I created a new site, and this builds a new Sharepoint_config database, but I still get the same error when trying to connect. I also checked the permissons in the SQL server manager. Created a new site, and added the old content database using the "stsadm addcontentdb" command.. but then I need to create a site collection, but when I create it, there is only a new site, but the rest are listed but there is no way to access them..

Any ideas thanks..


Re: SharePoint - Setup, Upgrade, Administration and Operation WSS 3.0 Disaster... Config database lost..

Henry Ong

save a backup of your content database and then run the configuration wizard again so it recreates your config database. you'll also have to recreate the web application but point it to your old content database instead of creating a new one.




Re: SharePoint - Setup, Upgrade, Administration and Operation WSS 3.0 Disaster... Config database lost..

Averied

Thanks for ur answer..

When creating a new application I don't get the option to point it to my old database, if I manually type the name of my old database I get an error while creating it, and now there is a new folder in the webroot, but no website..

Also I think I won't be able to access the website unless I create a new site collection, but when I do this I just get a new site at the homepage, but no clues to my old sites.. I can see my old sites in the site colection list, but not access them.. It' like of I need to activate them or something..

Can I please get some more details to completing the process, how do I point to my old content database when creating the application and activate it in the site collection .

Thanks...





Re: SharePoint - Setup, Upgrade, Administration and Operation WSS 3.0 Disaster... Config database lost..

Henry Ong

ahh... ok. go to central admin > application management > sharepoint web application management section > content databases link

switch to your web application from the drop down

click on the database name

take it offline and remove it

use the add a content database link

add your old content database

that should do it.






Re: SharePoint - Setup, Upgrade, Administration and Operation WSS 3.0 Disaster... Config database lost..

Averied

The thing is I installed a new WSS 3.0 in another server,

I did the process you told me, but when I try to open the site it returns 404 site not found..