Thomas N. Sørensen

Hi,

I have made a standard single server MOSS installation. Everything appears to be working fine, but I get errors when using stsadm to add solutions. (i.e. the Application Template Core, part of the server admin templates - http://www.microsoft.com/downloads/details.aspx FamilyId=C1039E13-94DA-4D7D-8CAE-3B96FA5A4045&displaylang=en).

Running i.e. "stsadm -o addsolution -filename ApplicationTemplateCore.wsp" gives the following error:

Object reference not set to an instance of an object. ApplicationTemplateCore.wsp: The Solution installation failed.

I get the excact same error, when I try to deploy Solutions using VSEWSS (November CTP).

Any ideas to solve this would be greatly appreciated.

Regards,

Thomas N. Sorensen



Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

aki

I seem to have the exact same issue, did you manage to solve this



Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

jos avn vlimmeren

I have the same problem when i try to deploy webparts for moss 2007 in visual studio 2005. I'm making webparts on the same computer for a couple of months but it's only since a couple of day's I get this error with every project I try to deploy (even if there are no files in it). I would appreciate it very much if anyone knows the solution to this



Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

Janie Pumphrey

I had the same error. I didn't have permission on the configuration & content database. After getting permission to the database, the error went away. I'm not sure if this is what's causing the problem in your case, but it worked for me.



Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

GOlson98507

I am having the same problem with Visual Studio. Here is what I am doing as a work around. If you look in the bin folder there is a batch file called setup.bat. It is a pain, but you can remove and deploy the part by opening the command prompt and navigating to the bin folder. Enter setup /uninstall or setup /install to remove or deploy the solution. This is not installing the assembly in the GAC so you will still need to do this manually. As a refresher go to start, then run and type 'assembly'. Just drag and drop your assembly there. Or as an alternative you can add some lines to the setup.bat, for example:

Code Snippet

@rem----------------------------------------------------------------------
@rem LDeploy
@rem----------------------------------------------------------------------
:LDeploy
echo Adding solution %PackageName% to the SharePoint ...
"%SPAdminTool%" -o addsolution -filename "%PackageFile%"

echo Deploying solution %PackageName% ...
"%SPAdminTool%" -o deploysolution -name "%PackageName%" -local -allowGacDeployment -url %TargetWebUrl%

echo Activating feature WebPart5 ...
"%SPAdminTool%" -o activatefeature -id 5be720ad-e963-404d-8026-2eecb5c4f6d0 -url %TargetSiteUrl%

"%programfiles%\Microsoft Visual Studio 8\SDK\v2.0\Bin\gacutil.exe" -if WebPart5.dll

iisreset

goto :EOF





Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

KlausKurzawa

I do also get this error trying install radEditorMOSS.wsp (telerik.com).

I have full permission in the farm but there must be something else that I should have permissions to.

Any help appreciated...

Klaus Kurzawa,

Sweden

(Updated by Klaus)
Found a solution of my problem:

My Computer -> Manage -> Added myself to WSS_RESTRICTED_WPG (Group for the Windows SharePoint Services farm administrator. This group is required for the WSS Administration Service to function.)





Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

Sunildalavay


I am getting this error while trying to add the solution using stsadm -o addsolution -filename "<drive>:\ApplicationTemplateCore.wsp" command


Initialization failure

<drive>:\ApplicationTemplateCore.wsp: The Solution installation failed.


Any help appreciated.


Sunil





Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

John Truxton

I am getting the same thing Sad Anyone found a soultion yet

C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\BIN>stsadm -o addsolution -filename d:\applicationtemplatecore.wsp

Object reference not set to an instance of an object.
d:\applicationtemplatecore.wsp: The Solution installation failed.





Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

Guilherme Rodrigues


According to this link: http://www.telerik.com/community/forums/thread/b311D-bachea.aspx, the problem is permission. First you have to be part of the Farm Administrator's. If you already part, go to My Computer --> Manage --> and add your user to the group WSS_RESTRICTED_WPG.





Re: SharePoint - Development and Programming stsadmin error: "Object reference not set to an instance of an object"

ksat

Guilherme is close - it is permissions-related.

But, from what I've discovered this morning, it also has to do with the SQL Admin Content database. The user executing the STSADM command must have full control access to this DB. I had this same problem and had my DBA add my user account to this DB w/ full control and reran the scripts with full success.