Daryll Holland

(edited)

Hi 

I'm trying to make full use of some of the new "Fantasic 40" but at the moment I'm not seeing them as so fantastic ;-).

The first template of interest for our company at the moment is the 'Room and Equipment Reservation' template for WSS 3.0, although we plan to implement more. I've created a site using the template and it's definately 100% in English (UK) format. However, the date order on the reservation tracking page is in US format i.e. 19th March is 3/19/07 when countries outside of the US (like us in the UK) would wish it to say 19/3/07. My site's regional settings are definately set to UK (also tried Australian to no avail).

When I tried to enter a reservation on 19th March by clicking in the time bar for a resource, it automatically fills in the form on the 'Reservations: New Item' page with US format date, which if I submit, Sharepoint tells me the date is out of range, however if I then change the date on the new item entry page to 19/3/2007 - it works. So my site's regional settings must be correct, it's just the Reservations page that's wrong.

Can anyone advise whether there is anything I can do about this (or where I can report it) as it seems like a bug to me.

Best regards

Daryll



Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Mike Walsh MVP

I can't find such a template. Do you mean the "Room and Equipment Reservations" template






Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Mike Walsh MVP

In that (Room and ...) I am seeing exactly the same thing (except that my settings are expecting dd.mm.yyyy not dd/mm/yyyy and I also have 24-hour specified which does not affect the page you mention which continues to show am and pm).

Obviously a case of US blindness (again)

Mike Walsh




Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Daryll Holland

That is the one - sorry Mike, I called my site Loans and Reservations, so I got confused.

Thanks for recreating the problem. It's such a shame that these things sometimes creep in to an otherwise very useful app.

Are there any official channels to report the problem to (I've put an entry on the template announcement page of the SP team blog)





Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Daryll Holland

UPDATE:

I've been playing around with the XSL editor (for the first time), and have modified the xsl on the reservations planner (bottom webpart on the Reservations page).

All I needed to do was replace <xsl:param name="lcid">1033</xsl:param> with <xsl:param name="lcid">5129</xsl:param>.

Shouldn't have had to do it, but that changed the date to UK format, so it's a good workaround!!





Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Mike Walsh MVP

Nice fix.

Thanks for adding it to the thread.

Mike




Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Mike Walsh MVP

I've added it to the WSSv3 FAQ here

http://www.asaris.de/sites/walsh/Lists/WSSv3%20FAQ/DispForm.aspx ID=1006

so that others with the same problem can hopefully find the solution.

Thanks again.

Mike




Re: SharePoint - General Question and Answers and Discussion 'Loans and Reservations' template bug?

Daryll Holland

No worries.

Daryll