thamizh

Background: I work at client's location. they have recently installed SP 2k7. I have to write some code to access SP site but I encounter some weird problems like:

1. I have C:\Prg Files\Common Files\MS Shared\web svr ext\40\isapi\ on my dev m/c. As far as i know, dev m/cs will hv isapi in 60. here the dev m/c has isapi in 40

2. The Win svr 2k3 on which SP 2k7 is installed has C:\Prg Files\Common Files\MS Shared\web svr ext\12\isapi\. instead of 40 and 60 folders, the svr has 12 and 50.

3. MS.SP.library, MS.SP.WebControls.dll, etc are missing in C:\...\isapi on server. but it has MS.SP, MS.SP.portal.dll files

4. .NET 2.0 and 3.0 are installed on svr but there is no folder called GAC in C:\Windows\assembly. instead all the .dll files are directly in assembly folder

5. the dev m/c has .net 1.1, and 2.0 but GAC is not on dev m/c. instead all the .dll files are directly in assembly folder.

i don't know why this is like this. i guess something's wrong with the installation. i need some expert advice. Anyone please share your suggestions about this.



Re: SharePoint - Enterprise Content Management SharePoint installation and configuration

Nagesh

The Assemblies you need to refer are

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\ISAPI\Microsoft.SharePoint.dll

C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\ISAPI\Microsoft.SharePoint.Security.dll

etc.

If you install the "Windows SharePoint Services 3.0 Tools: Visual Studio 2005 Extensions" they would be added when you create any sharepoint project.

Best Regards,

Nagesh