Gunston

Anyone else seen this problem starting up XACT It worked in the past but I haven't used it for a few weeks. In the interim, I've installed the Vista SDK, .NET Framework 3.0, WF and WCF extensions for Visual Studio etc.

I've uninstalled all these components and reinstalled GSE and Visual Studio Express but still get the same exception on start-up. In the debugger, I see Additional Information: System.Net.Dns threw an exception. I built a quick program to check I could use this class and it worked OK.

I'm going to post a duplicate of this question on the XACT forum.

Help !

Cheers.




Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Micael Baerens

Are you running it as Administrator Afair it's necessary.



Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Gunston

Micael

Thanks for the response. Yes, I always run as admin.






Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Shawn Hargreaves - MSFT

The XACT tool uses the 1.0 CLR. Do you have the 1.0 .NET runtime installed





Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Gunston

Shawn

1.1 any good

Thanks.






Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Shawn Hargreaves - MSFT

Yeah, I think that should work.





Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Gunston

I can use the System.Net.Dns class when referencing .NET 1.1 in a Console app.

Properties for referenced System.dll show:

C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\System.dll

Runtime version v1.1.4322

Version 1.0.5000.0






Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Gunston

@Shawn

Any more suggestions would be appreciated. Still have the same problem - might try the reinstall route again tonight.

Cheers.






Re: XNA Game Studio Express XACT - System.TypeInitializationException on start-up

Gunston

Just to close this thread down, I 'fixed' the problem by uninstalling the .NET Framework 1.1 and .NET Framework 2.0 and .NET Framework 3.0 and Visual C# Express and XNA Game Studio Express and then reinstalled .NET Framework 2.0 and Visual C# Express and XNA Game Studio Express... and it started working. Moral: I guess installing .NET Framework 3.0 or some of the new NetFX technologies broke something.

Cheers.