cada0310

Hey there,

I just installed the game studio for XNA and tried to build spacewar, but get this error about the FPU. Any quick tips

Thanks.

Error 1 Building content threw InvalidOperationException: The FPU is set to the wrong precision. The FBX SDK requires double precision to function properly.
at Microsoft.Xna.Framework.Content.Pipeline.FbxImporter.ValidateFpuState()
at Microsoft.Xna.Framework.Content.Pipeline.FbxImporter.Import(String filename, ContentImporterContext context)
at Microsoft.Xna.Framework.Content.Pipeline.ContentImporter`1.Microsoft.Xna.Framework.Content.Pipeline.IContentImporter.Import(String filename, ContentImporterContext context)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetDirectly(BuildItem item, String importerName)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAndLoadAsset(BuildItem item, BuildItem requestingItem)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAssetViaCache(BuildItem item, String importerName)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.ImportAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAssetWorker(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.BuildAsset(BuildItem item)
at Microsoft.Xna.Framework.Content.Pipeline.BuildCoordinator.RunTheBuild()
at Microsoft.Xna.Framework.Content.Pipeline.Tasks.BuildContent.RemoteProxy.RunTheBuild(BuildCoordinatorSettings settings, ITaskItem[] sourceAssets, TaskLoggingHelper msbuildLog, String[]& outputContent, String[]& rebuiltContent, String[]& intermediates) C:\Documents and Settings\CA\My Documents\Visual Studio 2005\Projects\MySpacewarWin1\MySpacewarWin1\Content\Models\p2_pencil.fbx MySpacewarWin1



Re: XNA Framework Newbie build error with Spacewar?

Eli Tayrien - MSFT

That's a strange one. What kind of processor do you have




Re: XNA Framework Newbie build error with Spacewar?

cada0310

Hi,

Thanks for the reply. It's a Pentium 4, 3.2GHz. 2GB of RAM. HP dc7600.

Let me know if there's anything else I can gather to help out...I'm eager to play with XNA. :-)





Re: XNA Framework Newbie build error with Spacewar?

Angelpulse

Yeah strange one that...

You can see some info on the FPU here

http://en.wikipedia.org/wiki/IEEE_754



Not sure if there are options within the OS to adjust the FPU precsion

Might help if you flashed upgraded your system board bios to the latest version (if not already done)





Re: XNA Framework Newbie build error with Spacewar?

Sentientv2

I actually got this error just now when I tried to take a custom made model from Maya (using the FBX exporter). I would suggest trying to make a new project and seeing if somehow your fbx got corrupted. I am assuming my problem is due to the fact I can't find any formal instructions on everything that needs to be in place before you export a model from Maya.

Seeing as how your case is a built in model from the template, try to make a new spacewar project and compile it. If you don't have any luck there, try uninstalling game studio express and reinstalling it (since the definition of the fbx file might be corrupted or something).

 

Best of luck!

 

-Sentientv2

<to update further testing> I actually cut everything out of the non working fbx file. Then I copied and pasted the working contents of the p1_saucer.fbx into my fbx file (p1_saucer1.fbx) and I still get the error. If I exclude this file from the project, the game runs just fine. It is not making any sense to me right now.

<and finally> I was able to load a mesh (the original saucer imported into maya and exported using the fbx exporter) in the game without receiving the error. still not sure what settings were on or off that were causing the problem.






Re: XNA Framework Newbie build error with Spacewar?

cada0310

Hi,

Thanks for your reply! So far, I've tried 3 times to create a new spacewar project from the built in template and build it, but I get the same error every time. I guess I'll give the uninstall/reinstall route a try unless anyone else has other ideas...

Chris





Re: XNA Framework Newbie build error with Spacewar?

cada0310

Well, this is quite strange. I upgraded my machine to Vista Business edition, and now I can compile and run Spacewar. How weird is that





Re: XNA Framework Newbie build error with Spacewar?

Sentientv2

I am glad to hear you got it working. I really can't explain my problems as well. Perhaps they're related somehow. Take care!

-Sentientv2





Re: XNA Framework Newbie build error with Spacewar?

Michael Klucher - MSFT

I'm glad that worked for you, please feel free to file a bug on the problem if you want. More information is here: http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=682921&SiteID=1&mode=1