prthealien

I have some huge source WAV files, which where compressed to the WaveBank using XACT. I want to debug/start my game without needing the WAVs (so they don't have to be downloaded/uploaded to a repository). Whenever I remove them, the compiler complains that they are missing. I thought sounds where played directly from the WaveBank
How do I tweak the settings so sounds can be played without the original WAVs


Re: Game Technolgies: XNA Build How to prevent XNA from needing WAV source files to play sounds?

Jim Perry

You don't need the original sounds to play the game, but you do need them to compile it. What do you mean "downloaded/uploaded to a repository"




Re: Game Technolgies: XNA Build How to prevent XNA from needing WAV source files to play sounds?

prthealien

The game files are kept on a Subversion repository so they can be shared with other members of the team that are also working on the game. It would be too much of a pain for the 50MB WAVs to be on the repository.

Anyway, how do I compile the WAVs so I don't need the originals I can't compile the game without the original WAV files.




Re: Game Technolgies: XNA Build How to prevent XNA from needing WAV source files to play sounds?

Jim Perry

prthealien wrote:
I can't compile the game without the original WAV files.

That's correct.






Re: Game Technolgies: XNA Build How to prevent XNA from needing WAV source files to play sounds?

prthealien

I got it. All I had to do is remove the xact project file from the Solution Explorer, and add the sound bank, wave bank, and .xgs file to the Solution Explorer, then in their Proporties set their copy actions to "Copy if newer"