Johannes Herbst

Since installation of TFS I am unable to see the content of the documents-folder (teamexplorer) on a client-machine. There is always a red cross on the folder!
If I start the team explorer on the server the documents folder is shown correctly.

I tried to copy the http-url (http://[servername]/sites/[Project]) to an IE on a client and there the sharepoint site is shown without any problems.

I did the changes required after installation of Sharepoint Portal Services SP2 (http://blogs.msdn.com/robcaron/archive/2005/10/07/478336.aspx).
I think I also configured the users like mentioned in the install guide (TFSInstall-v50926.chm - Managing Security Roles for Team Foundation Server).


Did anyone have a suggestion how to fix it





Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

blettner

I have the same problems like jherbst described above. Is this a problem with sharepoint services or TFS Beta 3



Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Matthew Watson

There may be something halfway down this web page about it:

http://www.amaxo.com/blog/archives/2005/04/simplify_author.html





Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Dan Kershaw

Can you try right-clicking on the [project] and selecting "Show project portal"   Is this option "grayed out"
I'm assuming here that when you run IE on the client, and you can navigate to the team project portal site, AND that you are running as the same user when using Team Explorer

If this is the case:
Can you take a look in the following folder on the client:
%USERPROFILE%\Local Settings\Application Data\Microsoft\Tea
m Foundation\1.0\Cache

In there should be a folder, with a GUID name. Go into this folder and open the "RegProxyFileCache.xml" file. Search for BaseSiteUrl and BaseSiteUnc. 
Can you verify that the server name for these entries is the same as [server] above




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

jherbst

Hi Matthew,

I think my server settings are the same like on the posted link.
I am able to create projects on the server and on my clients.

Hi Dan,
I verfified the settings in "RegProxyFileCache.xml" on my client-pc:
      <ServiceInterface>
        <Name>BaseSiteUrl</Name>
        <Url>http://PNSERVER4/sites</Url>
      </ServiceInterface>
      <ServiceInterface>
        <Name>BaseSiteUnc</Name>
        <Url>\\PNSERVER4\sites</Url>
      </ServiceInterface>


PNSERVER4 is the correct name of the server.

Best regards,
Johannes




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Dan Kershaw

This seems reasonable (assuming your server is PNSERVER4).
Can you verify if you can navigate to the Sharepoint site using the "Show Project Portal" item (as described above) or is this also grayed out

Thanks,




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

anasilk

I'm also got the same problem.I got this red cross not only on documents folder, but also reports folder and selecting "Show project portal" is grayed out" on client machine.any experts guide please...Smile




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Matthew Watson

Have you added your users to the three necessary places: The Team System project, the Project Portal and the Reporting Services Like this:

(1) Add user to appropriate project:
(1.1) Right-click project (or root project for all projects)
(1.2) Select "Team Project Settings".
(1.3) Select "Group Membership".
(1.2) Selecting the group to which you want to assign the user.
(1.4) Click the "Properties" button.
(1.5) Select the "Windows User or Group" radiobutton.
(1.6) Clicking the "Add..." button.
(1.7) Selecting the required user(s) and confirm it all.

(2) Add user to Project Portal:
(2.1) Right-click project and select "Show Project Portal".
(2.2) Click "Site Settings"
(2.3) In the "Administration" section, click "Manage Users"
(2.4) Click "Add Users"
(2.5) Fill in the list of users and follow the instructions.
      Note: User names include the domain, e.g DOMAINNAME\mwatson

(3) Add user to Reporting Services:
(3.1) Right-click project and select "Show Project Portal".
(3.2) Click "Reports".
(3.3) Click "Home".
(3.4) Click "Properties".
(3.5) Click "New Role Assignment"
(3.6) Add the new user(s), select their role(s) and click OK.
      Note: User names include the domain, e.g DOMAINNAME\mwatson





Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

jherbst

Sorry for my late response, I was not in the office the last week.

On my client I can use "Show Project Portal..." in VS.Net which opens successfully the sharepoint portal site in IE. But there is still a red cross on "documents" folder of the regarding project (team explorer).

I verified again the user settings and it seems it is correct set on my server.
I pasted below my user configuration of sharepoint project portal:

-----------------------------------------------------
Add Users Add Users
|
Remove Selected Users Remove Selected Users
|
Edit Site Groups of Selected Users Edit Site Groups of Selected Users
  Users User Name Site Groups
TFSSETUP PNDOM\tfssetup Administrator
  Domain Groups User Name Site Groups
pndom\tfs developers PNDOM\tfs developers Contributor
pndom\tfs project admins PNDOM\tfs project admins Administrator
pndom\tfs support PNDOM\tfs support Reader
-----------------------------------------------------

I am member of group "pndom\tfs project admins".




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

anasilk

now im using two machine for testing purposes. one of it using windows server 2003 trial version and another one is win2k3+SP1 Enterprise Edition.

i follow all Matthew Watson guides. unfortunately, only the trial machine is working not for the full version w2k3+SP1.

i've format and do the fresh installation of windows+sql server 2005+sharepoint services with SP1+foundation server+team explorer for 3 times on the win2k3+SP1 machine but it's doesn't work. still got cross mark at reports & documents folder.

help2..or it is because the beta product




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

jherbst

It seems my "red cross"-issue on documents folder is a client issue only.

On my PC I caní»t see the documents folder but on the PC of my colleagues they can see the folder without problems (they have the same security settings on the server like me).
The only difference is that I had installed and tested TFS-Beta 3 before and I tested Visual Studio 2005 Beta 2 and Release Candidate on my machine too. May there is something corrupt now. Tongue Tied

So I think it must have something to do which some settings on my PC which prevents the team explorer to show the documents-folder properly.
(I cleaned the folder
%USERPROFILE%\Local Settings\Application Data\Microsoft\Tea
m Foundation\1.0\Cache
before I start to install the beta3-refresh-client on my computer)

Are there other places which I can clean (registry, file system) before I start to install




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Dan Kershaw

Did you manage to cleanly install your client, and verify that this was your problem

You could try clearing the client side cache (See 3.1 in the link below): http://msdn.microsoft.com/vstudio/teamsystem/tfsknownissues.aspx#TeamExplorer

and run "devenv /resetuserdata"

Thanks,




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

jherbst

Hi Dan,

I cleaned the client side cache on my computer and reset also the user data of visual studio but it still shows a red cross on all documents folder Sad

Is there a switch to enable some kind of debugging/tracing/log on the client side to see whats happen there

best regards,
Johannes




Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Sergey Pikhulya

I have the same issue, have you resolved it



Re: Team Foundation Server - Administration Team Explorer - red cross on "documents"-folder

Johannes Herbst

I have still the issue wit the red cross on "documents" folder on my machine.
There are no news on how to fix this