GeneK

We have a web site that is using CR viewer with VS 2005 .NET 2.0. In the development environment the reports and viewer work without problem. We moved the site to our test server using the windows install process. The site installed and displays properly. When we request the report options, the viewer displays the reports correctly, but all of the viewer navigation buttons are displayed as broken link objects. Some of the buttons function properly, but the search, print, and export buttons all fail.

We have checked the aspnet_client\system_web\2_0_50727\CrystalReportWebFormViewer3 folder and all of the files appear to be where they belong. This is the first time we have tried to move a web site using CR into a test environment and we are not sure we have everything set properly on the web server.

Can anyone give me some ideas as what needs to be checked to figure out why these options are not working on the server, and how to reestablish the button links to the images.

Thanks!!

GeneK.



Re: Crystal Reports for Visual Studio Crystal Report Web Viewer not displaying navigation buttons.

TImmae

I am having the same problem. Everything works, but the grafiics for the navigation buttons are broken links. Any solutions yet




Re: Crystal Reports for Visual Studio Crystal Report Web Viewer not displaying navigation buttons.

GeneK

You are the first to respond to this thread. I have several others looking into this problem so if anyone else responds I will update this thread.

GeneK.





Re: Crystal Reports for Visual Studio Crystal Report Web Viewer not displaying navigation buttons.

GeneK

Resolution:

On my development system the following folders were added when I started working with the crystal report tools in VS.

C:\Inetpub\wwwroot\aspnet_client\system_web\2_0_50727\CrystalReportWebFormViewer3

There are several sub-folders under this location that contain the images and other required routines that handle the functionality of the veiwer control. Our system manager moved everything from the aspnet_client folder and below into our web site. All of the icons and functionality is now available through the viewer control.

GeneK.





Re: Crystal Reports for Visual Studio Crystal Report Web Viewer not displaying navigation buttons.

TImmae

Thanks to all. I looked at the source code from the web browser and found that the images and css files were not deploying to the web server. I, too, moved the files from the development machine to the web server. In order for the web app to work, I had to import the css file aslo.