rternier

The item '/EA Current Version/Remaining Work' cannot be found. (rsItemNotFound) Get Online Help

I checked the TFSwarehouse database and it Seems there are a few errors.

A week ago I moved the Databases from our C: to our E: on our appServer01 because C was running out of space. That might`ve caused this - not sure.

When I look at tables, say the Code Churn Table, I have the columns:

__ID
LInes Added
Lines Modified
LInes Deleted
Net Lines Added
__LastUpdateTime
__LastUPdatedBy
__TrackingID
Chanset
FileName
Date
Checked IN By
Team Project

I think the error is that i have `__` in the column names, but not sure. Any advice would rock.




Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

johnedw

Hi there, can you do me a favor and browse to http://<atserver>/Reports/

Let me know if you see the folder EA Current Version.

Thanks!
John

 





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

rternier

Once I enter EA Current Version I get the reports:

Bugs Found WithoutCorresponding Tests
Remainig Work
Related Work Items

I get no other reports.

Here's what happens when I select one of those three reports:

-REmaining Work-

  • Parameter validation failed. It is not possible to provide valid values for all parameters. (rsParameterError)

-Releated WOrk Items & Bugs Found Without Corresponding Tests

The Iteration DropDown is empty, so I cannot do the report. There are no values and I get a Alert box telling me to put a value in for the iteration

HOpe that helps.






Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

Mauli Shah - MSFT

can you please check the event viewer on the app tier and see if there are errors there

thanks,

mauli





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

rternier

Below is an error. As well, whenever we try to create a new Project in TFS - we get an error telling us the Wharehouse is corrupt.

Here are the errors in the Application log:




Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

Mauli Shah - MSFT

Could you make sure that the password for your service account on the app tier is current





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

rternier

The passwords have never been changed, and they are correct.





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

rternier

I went ahead and did all of this again:
http://forums.microsoft.com/MSDN/AddPost.aspx PostID=1104090&SiteID=1&ReturnUrl=

and it all turns out great.

I can  see the titles of all reports, but the Area & Iterations are not filling in when I select a report.

When I go to our CivicWEb project, I only get 3 reports (there should be like 10).

Note* We did move our DataBases from the C:\ to the E:\. I moved every DataBase and took them offline while I did this... would that cause this

Running Reports & Creating New projects do not work. if we don't have any answers soon we will wipe TFS and ALl data and reinstall.


EDIT---
The script here: http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=154526&SiteID=1

Does not work. If I change:

use TfsWarehouse
select top 1 LastUpdatedTime as [LastVCWHWrite] from dbo.[Code Churn] with (nolock) order by LastUpdatedTime desc

to

use TfsWarehouse
select top 1 __LastUpdatedTime as [LastVCWHWrite] from dbo.[Code Churn] with (nolock) order by __LastUpdatedTime desc

It works fine... I still think it has something to do with those "__" in the columns when I look at the DataTables






Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

rternier

So I reinstalled TFS totally. Erased the DB's, did all of that.

I can now create new TFS projects, which I couldn't before.
HOwever, I still get this error:

  • An error has occurred during report processing. (rsProcessingAborted)
    • Query execution failed for data set 'IterationParam'. (rsErrorExecutingCommand)
      • For more information about this error navigate to the report server on the local server machine, or enable remote errors

I believe it is because I moved the Databases from C:\....\data to E:\TFS\Data
I'm not sure yet.

I made sure all the permissions etc. were correct. ANy help would rock because we can't do reports now.





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

Othmane Rahmouni-MSFT

We purposely prefixed certain columns in the Warehouse with '__' so I believe that it is not the source of your problem.

I would like you to try the following two things:
- Check the DataDir setting on the Properties of your SQL Analysis Services Server(In Sql Server Management Studio, right click on the server and select properties), If it is pointing to the old drive then this might explain the error
- If that is not the issue, try to manually process the cube by right clicking on the warehouse database and selecting Process

Let me know how it goes.

Thanks,
Othmane





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

Mauli Shah - MSFT

hi there, were you able to find the answer to this issue



Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

rternier

I wasn't. We had to reinstall TFS to fix this and it worked for awhile. But now we're getting the same issue again.

Try to view a report on the portal and we get:
  • The item '/CivicWeb 2.x/Remaining Work' cannot be found. (rsItemNotFound) Get Online Help
Clicking Get Online Help goes to ->


Details
ID: rsItemNotFound
Source: Microsoft.ReportingServices.Diagnostics.Utilities.ErrorStrings


The Directory that all the TFS DataBases are in is: E:\Team Foundation Server\SQL Data
------------------
I'm looking at the DataDir of the Annalysis server in SQL 2005.
The Value of the DataDir: C:\Program Files\Microsoft SQL Server\MSSQL.2\OLAP\Data
Current Value: C:\Program Files\Microsoft SQL Server\MSSQL.2\OLAP\Data
Default Value: \data
restart: yes
Type: string
Units: folder
Category: basic
---------
I'm trying the Process ATM on the Analysis server and it Succeeded fully.





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

Mauli Shah - MSFT

Hi rternier,

Are you still working on this issue If so, please contact Microsoft Support - they can walk through the whole database setup with you. http://www.microsoft.com/services/microsoftservices/srv_support.mspx

I think you're right, it's probably related to the move of the dbs to another drive.

Mauli





Re: Team Foundation Server - Reporting & Warehouse Error when trying to generate report rsItemNotFound

Mauli Shah - MSFT

Hi rternier, Are you still working on this issue I would like to hear if you've gotten resolution on this; maybe your experience will help others.

Thanks!

Mauli