MikeGCompass

Hi,

I installed TFS and all was OK but before I had chance to do anything with it someone noticed that their web site was not working, went in and removed WSS from the default web site. (We had one small asp.net web site running on the server before install that has now been moved to another server)

Install said it was a success, but I didn't even get chance to creata a team project etc. so i don't even know if install was successfull

Now i get the error below (See end of post)

What I would like to know is, is there a way to put WSS back that doesn't involve reinstalling TFS from scratch!

I tried reenabling WSS from the central admin page but I still got errors and I'm not sure if I clicked the correct buttons etc. i.e. Which of the following options and what other options do I pick then...

Extend and create a content database

Extend and map to another virtual server

Can anyone advise

Also is it possible to just rerun TFS install to repair it

I'm asking now before I try anything becuase I'm anxious to avoid a reinstall.

Also if I have to reinstall TFS will I have to start with a fresh box or could I just reinstall over the existing messed up installtion

Other info:

-I do have another working TFS install that I'm trying to migrate from.

-Admin group in WSS is set up correctly

-Reporting services content management group is correctly assigned

-Version no of wss on my existing working site is 6.0.2.8117 on my new none working site its 6.0.2.6568

Many thanks in advance for any help,

Mike G

2007-09-12 11:04:42Z | Module: WSS | Thread: 7 | Verifying site template exists on the server using http://homer/_vti_bin/Sites.asmx
---begin Exception entry---
Time: 2007-09-12 11:04:42Z
Module: Engine
Event Description: TF30162: Task "SharePointPortal" from Group "Portal" failed
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: Unable to connect to the Windows SharePoint Services at homer
Exception Details: The Project Creation Wizard was not able to connect to the Windows SharePoint Services
at homer. The reason for the failed connection cannot be determined at this time.
Because the connection failed, the wizard was not able to complete creating
the Windows SharePoint Services site.
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Execute(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.TaskExecutor.PerformTask(IProjectComponentCreator componentCreator, ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.ProjectCreationEngine.RunTask(Object taskObj)
-- Inner Exception --
Exception Type: Microsoft.TeamFoundation.Client.PcwException
Exception Message: Unable to connect to the Windows SharePoint Services at homer
Exception Details: The Project Creation Wizard was not able to connect to the Windows SharePoint Services
at homer. The reason for the failed connection cannot be determined at this time.
Because the connection failed, the wizard was not able to complete creating
the Windows SharePoint Services site.
Stack Trace:
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Execute(ProjectCreationContext context, XmlNode taskXml)
-- end Inner Exception --
-- Inner Exception --
Exception Type: System.Net.WebException
Exception Message: The request failed with HTTP status 404: Not Found.
WebException: Response Status Code: NotFound
WebException: Response Status Message: Not Found
WebException: Status : ProtocolError
Stack Trace:
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
at Microsoft.TeamFoundation.Proxy.Portal.Sites.GetSiteTemplates(UInt32 LCID, Template[]& TemplateList)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.VerifySiteTemplate(ProjectCreationContext context, String template, Int32 lcid)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.ValidateSite(ProjectCreationContext context, XmlNode site)
at Microsoft.VisualStudio.TeamFoundation.WssSiteCreator.Validate(ProjectCreationContext context, XmlNode taskXml)
-- end Inner Exception --
--- end Exception entry ---

Note went directly to url mentioned in exception log (http://homer/_vti_bin/Sites.asmx) and this is what came back:

Server Error in '/' Application.


Re: Team Foundation Server - Setup Installed TFS OK but then someone removed the WSS from the Default Web Site

Will Lennon - MSFT

Mike,

What version of TFS and Sharepoint are you using

Are you using Sharepoint for any other purpose

Ie, can you uninstall/reinstall it and then reconfigure it for TFS

Thanks!

Will






Re: Team Foundation Server - Setup Installed TFS OK but then someone removed the WSS from the Default Web Site

MikeGCompass

Hi,

Using TFS 2005 SP1

Sharepoint sp2.

Nothing else on the server. (Not now anyway!)

After lots of trying to fix sharepoint gave up.

Uninstalled SQL, IIS, Sharepoint and then reinstalled.

I tried to uninstall Sharepoint only but this didn't fix anything I suspect it was the IIS reinstall that fixed it.

I'm really unimpressed with the TFS installation process this is my second one and each one seems to take weeks to get right.

Thanks,

Mike