Kanaida

I have a simple application in wich items at clicked on and the reportviewer loads a report with the following code:

Code Snippet

Me.ReportViewer1.ServerReport.ReportServerCredentials.NetworkCredentials = MyCredentials

Me.ReportViewer1.ServerReport.ReportServerUrl = _

New Uri("http://www.somewhere.com/reportserver", System.UriKind.Absolute)

Me.ReportViewer1.ServerReport.ReportPath = ReportPath

Me.ReportViewer1.RefreshReport()

On my development machine and other machines in my intranet the reports load fine as usual.

I have my home machine wich i connected to via remote desktop to test it remotely.

It opens up and when i click on a report the following happens within the report body:

'-1875238296' is not a valid value for 'Interval'. 'Interval' must be greater than 0.

I have to click the refresh icon in the control in order for the report to show up again. OK, so i thought maybe it's just some

wierd bug... it happens every time on that machine. I had to change it to:

Me.ReportViewer1.RefreshReport()

Me.ReportViewer1.RefreshReport()

Then it would load okay, but this is obviously not the proper way of doing it...

Since the code is so simple, I don't really see where i can find a solution...

If anyone can help i would appreciate it...

Note:

I also have VS 2005 installed on that machine at home, and it's patched up to date... minus .NET 3.0.

I don't have another machine to test it on at the moment.



Re: Visual Studio Report Controls Unusual ReportViewer Control Error during Refresh of a Remote Report

Feng Chen - MSFT

Hi Kanaida,
I am moving this thread from .NET Base Class Library forum to the Visual Studio Report Controls forum, since the issue is related to Visual Studio ReportViewer Control. There are more Visual Studio Report Controls experts in the Visual Studio Report Controls forum.
Thanks for your understanding!





Re: Visual Studio Report Controls Unusual ReportViewer Control Error during Refresh of a Remote Report

Kanaida

No one seemed to know anything or seen this error before i guess... but I did confirm it only happened at home with my pc that had VS2005 Installed.

I have no idea how, but the control must be a different version... who knows.





Re: Visual Studio Report Controls Unusual ReportViewer Control Error during Refresh of a Remote Report

Lisa Nicholls

It may not be the version of the control. Are you sure that the connection that you're making is actually working exactly the same way from your home network as it does elsewhere IOW, that your network credentials as supplied in your code snippet really get you into the server without any issues Can you test that outside the report context

What is your ServerReport.Timeout setting in the control, BTW It's the first thing that comes to mind when the error says "Interval", and that, plus the need for double refresh, is also one reason why I would want to check that the connection is being made as you expect... I'm wondering if the second hit re-offers the credentials and it gets taken the second time...

>L<






Re: Visual Studio Report Controls Unusual ReportViewer Control Error during Refresh of a Remote Report

Kanaida

You bet it works.. lol over 100 pc's now have it installed at over 10 different locations..

It was just my pc. Suddenly it just started to work after I included the reportviewer in the publishing part instead of making it a pre-requisite that gets installed via the RunTime components.