Happytechie

Hi All,

I'm trying to set up a TFS server for our development team to migrate to using and have run into an issue. During the install I get an error message that says:

Error 32000. The command line '"C:\prgram Files\Common Files\Microsoft Shared\Web Server Extensions\60\bin\Stsadm.exe" ...' returned non-zero value -2130242250.

it has a Retry and a Cancel button. Retry brings me the same error and cancel rolls the install out, following the roll out I get a setup.exe error box that informs me that MS Visual Studio 2005 Team Foundation Server - ENU has encountered a problem during setup.

It want's me to send a report to you guys at MS (which I do).

has anybody got any ideas where I can go from here

If you need mroe information / install log extracts just shout and I'll do my best.

Thanks in advance for your help.

Paul

edit:

log file excerpt:

SQL Server Reporting Services have been successfully configured.
05/22/07 13:19:46 DDSet_Status: Process returned 0
05/22/07 13:19:46 DDSet_Status: Commandline '"D:\Program Files\Microsoft Visual Studio 2005 Team Foundation Server\Tools\TFRSConfig.exe" /verify' returned 0
05/22/07 13:19:46 DDSet_CARetVal: 0
05/22/07 13:19:46 DDSet_Status: QuietExec returned 0
MSI (s) (18:48) [13:19:46:248]: Executing op: ActionStart(Name=CA_QuietExec,,)
05/22/07 13:19:46 DDSet_Exit: QuietExec ended
MSI (s) (18:48) [13:19:46:248]: Executing op: CustomActionSchedule(Action=CA_QuietExec,ActionType=25601,Source=BinaryData,Target=**********,CustomActionData=**********)
MSI (s) (18:44) [13:19:46:295]: Invoking remote custom action. DLL: C:\WINDOWS\Installer\MSIC773.tmp, Entrypoint: QuietExec
05/22/07 13:19:46 DDSet_Status: LANGID: 1033
05/22/07 13:19:46 DDSet_Entry: QuietExec started
05/22/07 13:19:46 DDSet_Status: Hiding command line parameters
05/22/07 13:19:46 DDSet_Status: Commandline: "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\60\Bin\Stsadm.exe" ...
05/22/07 13:19:46 DDSet_Status: IgnoreExitCode: 0
05/22/07 13:19:46 DDSet_Status: Silent: 0
05/22/07 13:19:46 DDSet_Status: ActionStart: 0
05/22/07 13:19:46 DDSet_Status: Cost: 0
05/22/07 13:19:46 DDSet_Status: WorkingDirectory:
05/22/07 13:19:46 DDSet_Status: HideCmdLine: 1

Server extensions administration port not found.

05/22/07 13:19:53 DDSet_Status: Process returned -2130242250
05/22/07 13:19:53 DDSet_Error: The Commandline '"C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\60\Bin\Stsadm.exe" ...' returned non-zero value: -2130242250.
MSI (s) (18!E8) [13:33:29:612]: Product: Microsoft Visual Studio 2005 Team Foundation Server - ENU -- Error 32000.The Commandline '"C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\60\Bin\Stsadm.exe" ...' returned non-zero value: -2130242250.

05/22/07 13:33:29 DDSet_CARetVal: 32000
05/22/07 13:33:29 DDSet_Status: QuietExec returned 32000
05/22/07 13:33:29 DDSet_Exit: QuietExec ended
MSI (s) (18:48) [13:33:29:690]: User policy value 'DisableRollback' is 0
MSI (s) (18:48) [13:33:29:690]: Machine policy value 'DisableRollback' is 0
Action ended 13:33:29: InstallFinalize. Return value 3.
MSI (s) (18:48) [13:33:29:706]: Executing op: Header(Signatur



Re: Team Foundation Server - Setup Error 32000 on TFS Workgroup server install

Happytechie

does anybody have any ideas

I've checked and as for as I can make out there are no front page extensions installed as far as I can make out. The server is fully patched up. It is a real physical machine (no t a virtual server) and has 1.25 Gb of RAM according to the system properties dialogue. The only warning that I get in the pre install check is that the CPU is underspeed.

I've reinstalled sharepoint services for windows according to the latest TFS install guide.

I'd really like to get the team started using TFS rather than the bodged together system we have now as I know it will help us increase the quality of our output. Unfortunately like the rest of you I don't have any real time to spend on it and would have liked to just follow the guide and install the product.

Thanks in advance again.

Paul





Re: Team Foundation Server - Setup Error 32000 on TFS Workgroup server install

Happytechie

according to this page:

http://blogs.msdn.com/willbu/archive/2006/08/23/Common-Team-Foundation-Server-installation-errors-and-possible-resolutions.aspx

which should probably be linked to from the common errors page

The error number I got is a bum sharepoint services install, so I'll re install those and try again.





Re: Team Foundation Server - Setup Error 32000 on TFS Workgroup server install

Hua Chen - MSFT

Hello Paul:

Could you please check the following thread to see if there is a way for your question

Possible 32000 and 26105 error solutions:
http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=20753&SiteID=1

Here are some suggestions you may try:

1. Uninstall WSS 2.0
2. Check the App - Pools to remove all application pools used by WSS 2.0.
3. Restart machine
4. Install application the WSS 2.0 with SP2

Good luck.






Re: Team Foundation Server - Setup Error 32000 on TFS Workgroup server install

Happytechie

thanks for that advice,

I've uninstalled wss, deleted the application pools, rebooted and reinstalled WSS 2.0 SP2 with the command line:

STSV2.EXE /C:"setupsts.exe /remoteSql=yes /provision=no /qn+"

The setup pages for WSS are available. I left these as default and re run the TFS workgroup install.

I then re ran the installer and it seems to have run to completion with no errors.

Thanks for your help. Could I sugest that the installer should probably check that it will be able to create the required application pools when it checks that WSS 2.0SP2 has been installed

I suspect I'll be adding more questions to the setup forum fairly qsoon.