CodeGreen

I have a GA solution that I have been working on for a few days now, testing the setup it creates on a separate machine. Today I wanted to try attaching with the debugger, so for the first time I tried using the 'Register' receipe to register it on my Dev machine. It seemed to lock up, I left it running for 30 minutes (the status bar says to be patient after all), then ended the task. Now the solution no longer has the Guidance Navigator, or any of the GAT context menu options. Any help would be greatly appreciated!

Thanks,

Danny



Re: Visual Studio Guidance Automation Toolkit Solution no longer GAT solution

CodeGreen

Actually, it seems my installation of GAT seems broken. When I try and create a new Guidance package I get the error:

Value cannot be Null.

Parameter name: serviceProvider.

System.ArgumentNullException: Value cannot be null.
Parameter name: serviceProvider
at Microsoft.Practices.ComponentModel.ServiceHelper.GetService(IServiceProvider serviceProvider, Type serviceType, Object component)
at Microsoft.Practices.RecipeFramework.VisualStudio.Templates.VszWizard.EnvDTE.IDTWizard.Execute(Object Application, Int32 hwndOwner, Object[]& ContextParams, Object[]& CustomParams, wizardResult& retval)

I have tried running repair on both GAX and GAT, no help.

I am very excited about GAT, but after investing 2 days and now nothing to show I think my manager is going to pull the plug on the concept. Please Help!!





Re: Visual Studio Guidance Automation Toolkit Solution no longer GAT solution

CodeGreen

Please note that I have completely un-installed and re-installed both GAT and GAX a couple of times as well, with no success. The error still occurs whenever I try to start a new GA project.



Re: Visual Studio Guidance Automation Toolkit Solution no longer GAT solution

vga

Hi,

Can you provide the OS, VS, GAX, SPs, versions you're using We can start looking at common issues with the different common OS and Visual Studio combinations.

thanks,
-Victor.





Re: Visual Studio Guidance Automation Toolkit Solution no longer GAT solution

CodeGreen

After attempting to uninstall the Smart Client SF (the uninstall failed), and then re-installing GAX and GAT, things seem to be working again.

Thanks!





Re: Visual Studio Guidance Automation Toolkit Solution no longer GAT solution

vga

Great to hear that!