Gumbatman

Hello,

I can open a Crystal Report without any problems on my C# page. However, if I add a parameter to the report, I get a logon error. If I remove the parameter from the report, the error goes away and the report displays as expected. This is connecting to an Oracle database.

What does entering a parameter have to do with logging into the database How do I logon onto the database so I can pass the paramters

I've seen some examples of how to pass parameters in code, but I am having a hard time finding that along with logging into the Oracle database.

Thank you for the help.

-Gumbatman



Re: Crystal Reports for Visual Studio Logon Error when passing a parameter on .Net page

jaortizgonzalez

Hello

You don't need specify logon, please show me your code.

Bye






Re: Crystal Reports for Visual Studio Logon Error when passing a parameter on .Net page

Gumbatman

jaortizhonzalez,

Thank you for responding to my question. However, as I was cleaning up the code so it could be readable on the site it suddenly worked!

I am not too sure about the changes I made. It appears that the only change was where there UDL for the source was placed. When it was on my C: drive, it seemed to work, but it didn't work when the UDL was on my D: drive. I know that doesn't make too much sense, but that was one potential issue. The other thing, with the UDL was that I may have connected directly to the Oracle source and not used the UDL.

Also, to post the code, I was going through the steps again to make sure I could document it clearly. It didn't make a difference whether I created the report in Crystal or .NET. I wish I knew how I solved it.

If I come across this again, I will post it.

Thank you for the help.

-Gumbatman