JoEllen West

Test manager seems to have stopped working for me.  Whenever I try to start it, a popup 'Exception has been thrown by the target of an invocation.'  The solution is in source control, and I noticed problems after multiple users started using the project.  I have re-installed VSTS and still have the problem, even with a new solution.  And here's the xml of a new vsmdi file (I reset settings before I created this) --- does it look correct

< xml version="1.0" encoding="utf-8" >

<Tests>

<edtdocversion branch="retail" build="50727" revision="42" />

<TestCategory type="Microsoft.VisualStudio.TestTools.Common.TestCategory">

<id type="Microsoft.VisualStudio.TestTools.Common.TestCategoryId">

<id type="System.Guid">8c43106b-9dc1-4907-a29f-aa66a61bf5b6</id>

</id>

<name type="System.String">Lists of Tests</name>

<description type="System.String" />

<enabled type="System.Boolean">True</enabled>

<parentCategoryId type="Microsoft.VisualStudio.TestTools.Common.TestCategoryId">

<id type="System.Guid">00000000-0000-0000-0000-000000000000</id>

</parentCategoryId>

<runConfiguration type="Microsoft.VisualStudio.TestTools.Common.Link">

<id type="System.Guid">23988696-6702-441f-b9be-b322edb8404a</id>

<name type="System.String">Local Test Run</name>

<storage type="System.String">localtestrun.testrunconfig</storage>

<type type="System.Type, mscorlib">Microsoft.VisualStudio.TestTools.Common.TestRunConfiguration</type>

<enabled type="System.Boolean">True</enabled>

</runConfiguration>

</TestCategory>

</Tests>

What else can I try

 

 



Re: Visual Studio Team System - Testing Error opening vsmdi file

David Gorena Elizondo - MSFT

Hello,

The .vsmdi that you provided is correct. Have you tried doing "devenv /resetuserdata" from a VS command prompt

Thanks,
David Gorena Elizondo
[MSFT] VSTS





Re: Visual Studio Team System - Testing Error opening vsmdi file

JoEllen West

That worked. Thanks!



Re: Visual Studio Team System - Testing Error opening vsmdi file

drf71

David Gorena Elizondo - MSFT wrote:

Hello,

The .vsmdi that you provided is correct. Have you tried doing "devenv /resetuserdata" from a VS command prompt

Thanks,
David Gorena Elizondo
[MSFT] VSTS

I had my team try this suggestion, without success. I'm thinking about rebuilding this file, but would like some level of confidence that I understand what causes the issue, so we don't have to deal with it again and again.

Mr. Elizondo - Can you shed some light on the possible cause

I'm assuming that this vsmdi file was intended for normal team use via source control. We've noted odd load behavior, where the Test Mgr window comes up blank, the "invocation error is thrown" or the root List structure is visibile without sub nodes. Often, a restart of Studio resolved these issues, except for the more recent "invocation" errors.

Thanks for any additional advice you can provide.