strong_epoxy

Occasionally, different developers will experience TF31003 errors when trying to communicate with TFS. Trying again after a while seems to clear the problem up.

Has anyone else seen this Does anyone know of a fix How would I troubleshoot this


Re: Team Foundation Server - Administration Intermittent TF31003 errors.

Adam Singer - MSFT

Are there any messages in the Application Event Log on the TFS Application Tier around the time someone sees one of these failures

Cheers,

Adam






Re: Team Foundation Server - Administration Intermittent TF31003 errors.

Adam Singer - MSFT

Are you still seeing these issues

Cheers,

Adam






Re: Team Foundation Server - Administration Intermittent TF31003 errors.

strong_epoxy

We're in the middle of a holiday so there hasn't been an opportunity to repro the bug. When it happens again we'll collect the user name and all the logs.

Generally, we're not seeing any errors in the Application Log. The TFS web log is reasonably clean though we are seeing the following errors:

Code Snippet

2007-03-26 15:42:25 W3SVC3 10.180.7.29 POST /VersionControl/v1.0/repository.asmx - 8080 DOMAIN\USERNAME 172.25.6.2 Team+Foundation+(devenv.exe,+8.0.50727.762) 200 0 0
2007-03-26 15:42:25 W3SVC3 10.180.7.29 POST /VersionControl/v1.0/repository.asmx - 8080 - 172.25.6.2 Team+Foundation+(devenv.exe,+8.0.50727.762) 401 2 2148074254
2007-03-26 15:42:26 W3SVC3 10.180.7.29 POST /VersionControl/v1.0/repository.asmx - 8080 - 172.25.6.2 Team+Foundation+(devenv.exe,+8.0.50727.762) 401 1 0



Note the first entry is a success and includes the DOMAIN\USERNAME credentials. The subsequent entries are errors and do not include the credentials, rather a simple '-'

Don't know if it could be related but the timing and user coincidences are suspicious.

I'll post more information as we find it.