MarkZach

Hi,

I'm completely unable to get the team proxy working and I can't diagnose it at all. The installation was fine but when I try to use the proxy I get

The source control proxy 'myserver.us.com' is not responding, so the request will be sent to the main server. Please verify your settings.

Additional information:

TF30063: You are not authorized to access Microsoft-IIS/6.0.

Looking at the w3svc log I'm getting 401 errors on the proxy server but I can't tell where they're coming from. I can't even figure out who is unable to access IIS. Is this on the proxy or in the proxy->server communications or what

Can anyone help me figure out how to even diagnose this I tried this on our local network hub (i.e. with the proxy physically next to the server) and still get this issue. We do use some web caching stuff in the office and I don't think it was on the same local net as the server.

Still, it would sure be nice if there was a bit more diagnostic info.

Thanks,

Mark



Re: Team Foundation Server - Version Control Authorization issues with Team Proxy Server

Sudhir Hasbe - MSFT

Hey Mark I am moving this to Version Control group. They handle the proxy issues I am sure someone will be able to help out. I will also assign this to someone on that team. Hope we can get a solution to your problem soon.




Re: Team Foundation Server - Version Control Authorization issues with Team Proxy Server

MarkZach

Hi,

I might have resolved this. Apparently what I did wrong was install the proxy while logged in as local administrator (I guess) and as a result the web site didn't have any domain-specific permissions. I just went to the IIS admin and right-clicked the VSproxy website then selected permissions and added the domain-specific TFSproxy user.

Does this seem right

More on this. Although that seemed to fix it, in fact it worked for about an houra nd then stopped. Here's part of the w3svc log... Notice here I get 4 failures and two successes. After that it's all failures but before this part of the log are hundreds of successes (I did a get of the entire project just fine). It's as if a reverse IP lookup didn't work.

2007-06-20 14:37:35 141.121.238.183 GET /VersionControlProxy/V1.0/item.asmx sfid=12832,8971,0,0,0,0,0,0,0,0&ts=633180334547682042&s=JMt2w25CvJ4iVFVQcbLe1%2BPtcs8ZyW%2BtQ9%2Fq0IP9iblahCKdlgKvWx4Yu1vG8r0rPgUujU53EJt%2FN2fw5OWs%2BL5mnlXxn5Vw%2FBfA0rvrRbtKhIDqaWpeyWSYmjlKG%2B6RqKOoy6uBC%2B0Daz3yBjqcmYM702JF41vZf3f512zPDo8%3D&fid=8971&rid=272ee40f-8145-4b0e-ae46-2979f16f6b57 8081 - 140.29.158.141 Team+Foundation+(devenv.exe,+8.0.50727.762) 401 2 2148074254
2007-06-20 14:37:35 111.121.238.183 GET /VersionControlProxy/V1.0/item.asmx sfid=12832,8971,0,0,0,0,0,0,0,0&ts=633180334547682042&s=JMt2w25CvJ4iVFVQcbLe1%2BPtcs8ZyW%2BtQ9%2Fq0IP9iblahCKdlgKvWx4Yu1vG8r0rPgUujU53EJt%2FN2fw5OWs%2BL5mnlXxn5Vw%2FBfA0rvrRbtKhIDqaWpeyWSYmjlKG%2B6RqKOoy6uBC%2B0Daz3yBjqcmYM702JF41vZf3f512zPDo8%3D&fid=12832&rid=272ee40f-8145-4b0e-ae46-2979f16f6b57 8081 - 140.29.158.141 Team+Foundation+(devenv.exe,+8.0.50727.762) 401 2 2148074254
2007-06-20 14:37:35 111.121.238.183 GET /VersionControlProxy/V1.0/item.asmx sfid=12832,8971,0,0,0,0,0,0,0,0&ts=633180334547682042&s=JMt2w25CvJ4iVFVQcbLe1%2BPtcs8ZyW%2BtQ9%2Fq0IP9iblahCKdlgKvWx4Yu1vG8r0rPgUujU53EJt%2FN2fw5OWs%2BL5mnlXxn5Vw%2FBfA0rvrRbtKhIDqaWpeyWSYmjlKG%2B6RqKOoy6uBC%2B0Daz3yBjqcmYM702JF41vZf3f512zPDo8%3D&fid=8971&rid=272ee40f-8145-4b0e-ae46-2979f16f6b57 8081 - 140.29.158.141 Team+Foundation+(devenv.exe,+8.0.50727.762) 401 1 0
2007-06-20 14:37:35 111.121.238.183 GET /VersionControlProxy/V1.0/item.asmx sfid=12832,8971,0,0,0,0,0,0,0,0&ts=633180334547682042&s=JMt2w25CvJ4iVFVQcbLe1%2BPtcs8ZyW%2BtQ9%2Fq0IP9iblahCKdlgKvWx4Yu1vG8r0rPgUujU53EJt%2FN2fw5OWs%2BL5mnlXxn5Vw%2FBfA0rvrRbtKhIDqaWpeyWSYmjlKG%2B6RqKOoy6uBC%2B0Daz3yBjqcmYM702JF41vZf3f512zPDo8%3D&fid=12832&rid=272ee40f-8145-4b0e-ae46-2979f16f6b57 8081 - 140.29.158.141 Team+Foundation+(devenv.exe,+8.0.50727.762) 401 1 0
2007-06-20 14:37:35 111.121.238.183 GET /VersionControlProxy/V1.0/item.asmx sfid=12832,8971,0,0,0,0,0,0,0,0&ts=633180334547682042&s=JMt2w25CvJ4iVFVQcbLe1%2BPtcs8ZyW%2BtQ9%2Fq0IP9iblahCKdlgKvWx4Yu1vG8r0rPgUujU53EJt%2FN2fw5OWs%2BL5mnlXxn5Vw%2FBfA0rvrRbtKhIDqaWpeyWSYmjlKG%2B6RqKOoy6uBC%2B0Daz3yBjqcmYM702JF41vZf3f512zPDo8%3D&fid=12832&rid=272ee40f-8145-4b0e-ae46-2979f16f6b57 8081 mydomain\me 140.29.158.141 Team+Foundation+(devenv.exe,+8.0.50727.762) 200 0 0
2007-06-20 14:37:36 111.121.238.183 GET /VersionControlProxy/V1.0/item.asmx sfid=12832,8971,0,0,0,0,0,0,0,0&ts=633180334547682042&s=JMt2w25CvJ4iVFVQcbLe1%2BPtcs8ZyW%2BtQ9%2Fq0IP9iblahCKdlgKvWx4Yu1vG8r0rPgUujU53EJt%2FN2fw5OWs%2BL5mnlXxn5Vw%2FBfA0rvrRbtKhIDqaWpeyWSYmjlKG%2B6RqKOoy6uBC%2B0Daz3yBjqcmYM702JF41vZf3f512zPDo8%3D&fid=8971&rid=272ee40f-8145-4b0e-ae46-2979f16f6b57 8081 mydomain\me130.29.158.141 Team+Foundation+(devenv.exe,+8.0.50727.762) 200 0 0

Mark





Re: Team Foundation Server - Version Control Authorization issues with Team Proxy Server

MarkZach

I have absolutely solved this, it's our corporate proxy policy.

If I go to Internet Explorer and turn off all the proxy stuff of course my web browser no longer works but the TFS Proxy works fine. Temporarily I've fixed this by using an LMHOSTS file and creating a netbios name for the proxy. This seems kludgy and any more permanent answer would be appreciated.

Mark