Dave P2

Hi,

I have a VS2005 build failing with an error thrown saying "References root node unavailable". I have attached a diagnostics log below but I can't see any error that points to anything in particular.

Has anyone seen an error like this before or have any suggestions to diagnse what might be causing it

Thanks,

Dave

Target "CoreResGen" in file "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets":

Task "GenerateResource"

"C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\bin\Resgen.exe" /useSourcePath /r:CHChart.dll /r:C:\_cvs\ViewPoint\_PPC_DataEngineDotNet\bin\Release\DataEngineDotNet.dll /r:C:\_cvs\ViewPoint\_PPC_DataEngineHelper\bin\Release\DataEngineHelper.dll /r:LEDControl.dll /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\Microsoft.WindowsCE.Forms.dll" /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\mscorlib.dll" /r:OpenNETCF\OpenNETCF.dll /r:OpenNETCF\OpenNETCF.Windows.Forms.dll /r:OpenNETCF\OpenNETCF.WindowsCE.Forms.dll /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\System.Data.dll" /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\System.dll" /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\System.Drawing.dll" /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\System.Windows.Forms.DataGrid.dll" /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\System.Windows.Forms.dll" /r:"C:\Program Files\Microsoft Visual Studio 8\SmartDevices\SDK\CompactFramework\2.0\v2.0\WindowsCE\System.Xml.dll" /compile Main.resx,obj\Release\_PPC_ViewPoint.Main.resources MainStrings.resx,obj\Release\_PPC_ViewPoint.MainStrings.resources Properties\Resources.resx,obj\Release\_PPC_ViewPoint.Properties.Resources.resources

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(1616,9): error MSB4018: The "GenerateResource" task failed unexpectedly.

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(1616,9): error MSB4018: System.Runtime.InteropServices.COMException (0x80004005): References root node unavailable.

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(1616,9): error MSB4018: at Microsoft.Build.Shared.ExceptionHandling.RethrowUnlessFileIO(Exception e)

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(1616,9): error MSB4018: at Microsoft.Build.Tasks.GenerateResource.NeedSeparateAppDomain()

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(1616,9): error MSB4018: at Microsoft.Build.Tasks.GenerateResource.Execute()

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets(1616,9): error MSB4018: at Microsoft.Build.BuildEngine.TaskEngine.ExecuteTask(ExecutionMode howToExecuteTask, Hashtable projectItemsAvailableToTask, BuildPropertyGroup projectPropertiesAvailableToTask, Boolean& taskClassWasFound)

Done executing task "GenerateResource" -- FAILED.

Done building target "CoreResGen" in project "_PPC_ViewPoint.csproj" -- FAILED.

Target "_CheckForCompileOutputs" in file "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets":

Task "CreateItem" skipped, due to false condition; (Exists('@(IntermediateAssembly)')) was evaluated as (Exists('obj\Release\ViewPointClient.exe')).

Task "CreateProperty"

Done executing task "CreateProperty".

Task "CreateItem" skipped, due to false condition; ('$(_DocumentationFileProduced)'=='true') was evaluated as ('false'=='true').

Task "CreateProperty"

Done executing task "CreateProperty".

Task "CreateItem" skipped, due to false condition; ('$(_DebugSymbolsProduced)'=='true') was evaluated as ('false'=='true').

Done building target "_CheckForCompileOutputs" in project "_PPC_ViewPoint.csproj".

Target "_SGenCheckForOutputs" skipped, due to false condition; ('$(_SGenGenerateSerializationAssembliesConfig)' == 'On' or ('@(WebReferenceUrl)'!='' and '$(_SGenGenerateSerializationAssembliesConfig)' == 'Auto')) was evaluated as ('Off' == 'On' or (''!='' and 'Off' == 'Auto')).

Target "_CleanGetCurrentAndPriorFileWrites" in file "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets":

Task "ReadLinesFromFile"

Done executing task "ReadLinesFromFile".

Task "CreateItem"

Done executing task "CreateItem".

Task "FindUnderPath"

Comparison path is "C:\_cvs\ViewPoint\_PPC_ViewPoint".

Done executing task "FindUnderPath".

Task "FindUnderPath"

Comparison path is "bin\Release\".

Path "C:\_cvs\ViewPoint\_PPC_ViewPoint\obj\Release\ResolveAssemblyReference.cache" is outside the comparison path.

Done executing task "FindUnderPath".

Task "FindUnderPath"

Comparison path is "obj\Release\".

Path "C:\_cvs\ViewPoint\_PPC_ViewPoint\obj\Release\ResolveAssemblyReference.cache" is inside the comparison path.

Done executing task "FindUnderPath".

Task "CreateItem"

Done executing task "CreateItem".

Task "RemoveDuplicates"

Done executing task "RemoveDuplicates".

Done building target "_CleanGetCurrentAndPriorFileWrites" in project "_PPC_ViewPoint.csproj".

Target "_CleanRecordFileWrites" in file "C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Microsoft.Common.targets":

Task "RemoveDuplicates"

Done executing task "RemoveDuplicates".

Task "MakeDir"

Done executing task "MakeDir".

Task "WriteLinesToFile"

Done executing task "WriteLinesToFile".

Done building target "_CleanRecordFileWrites" in project "_PPC_ViewPoint.csproj".

Done building project "_PPC_ViewPoint.csproj" -- FAILED.

Build FAILED.



Re: Visual Studio MSBuild Resgen: References root node unavailable

DanMoseley - MSFT

Dave, we haven't seen this before. We need a way to reproduce it at our end to investigate.

Can you reduce your project down to the minimum required to reproduce it (likely, you'll be able to remove almost all the source code) and attach it to a bug Bug opening information is at the top of this forum.

Dan






Re: Visual Studio MSBuild Resgen: References root node unavailable

JadeS

I ran into this problem too, though i was able to build my solution, I could not design forms visually. Since Google only yields 2 results for "References root node unavailable" I figured i'd post my resolution in one of them. I'm not sure exactly which step fixed it, but I performed a Build -> Clean Solution, then Build -> Build Solution. Still had the issue, checked everything in to SourceSafe, and reloaded the IDE. Now it works.





Re: Visual Studio MSBuild Resgen: References root node unavailable

hattonj

Restarting the IDE alone did it for me.




Re: Visual Studio MSBuild Resgen: References root node unavailable

kazhian

I wanted to copy a form from solution to another.

So, copied form.designer.vb, form.vb & form.rex into new solution.

but when I opend the form in design mode I got References root node unavailable.

The I cleaned, rebuilt. Still got the error and finally, I closed all IDEs and opend. THE PROBLEM SOLVED.






Re: Visual Studio MSBuild Resgen: References root node unavailable

skhoo

Have the exact same error after renaming the form name in the .Designer.cs module.

Created a new form and the designer is still broken with the same error.

Like all of you, this error goes away after reopening the VS2005 IDE.





Re: Visual Studio MSBuild Resgen: References root node unavailable

Neal

I just had the same issue. VS2005 SP1. Will try restarting. I was trying to create a ProjectInstaller for a Windows Service. I can build just fine from sources, but have been unable to touch the designer. I did not do a rebuild or clean compile, just a simple restart of VS seems to have resolved it for me.




Re: Visual Studio MSBuild Resgen: References root node unavailable

LorenzoSacco

I had the same problem with Visual Studio 2005. I was able to build my solution and view designer of the aspx page. I restarted the IDE and the problem disappear!



Re: Visual Studio MSBuild Resgen: References root node unavailable

Rakshit Bakshi

Restart the IDE, That's the only solution.