Balagangadharan.R

Hello All

I creted an Windows Application Using VS 2003, I created Setup.

When Im installing in Client Place it some time Works and Some times its Shows Error . The Error is

THERE IS PROBLEM WITH THIS WINDOWS INSTALLER PACKAGE. A DLL REQUIRED FOR THIS INSTALL TO COMPLETE COULD NOT BE RUN. CONTACT YOUR SUPPORT PERSONNAL OR PACKAGE VENDOR.

PLEASE HELP TO BUG TIS OUT

THANX IN ADVANCE.




Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP


Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP

Balagangadharan.R

Hello Manan

Thanks for replying, i need to know whether this problem occurs due to my setup or windows installer

Please reply






Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP

Manan Thakkar

There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

This may be windows installer error...

Workaround:
There is a known issue with WMI.Net. Resolve this issue by registering the wmiutils.dll file as follows:
  1. Click Start, and then click Run.
  2. In the Run window, type: regsvr32 wmiutils.dll
  3. Click OK.

Try this...






Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP

PhilWilson

Do you have any custom actions or installer classes




Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP

Balagangadharan.R

Hello PhilWilson

No i dont have any installer classes






Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP

skewlboy

TRY REINSTALLING WINDOWS INSTALLER 3.0 OR 3.1 - I DID THIS AND IT WORKED FOR ME. I WAS GETTING THE EXACT SAME ERROR MESSAGE.

WINDOWS INSTALLER 3.0 DOWNLOAD:
http://www.microsoft.com/downloads/details.aspx familyid=5FBC5470-B259-4733-A914-A956122E08E8&displaylang=en

WINDOWS INSTALLER 3.1 DOWNLOAD:
http://www.microsoft.com/downloads/details.aspx familyid=889482FC-5F56-4A38-B838-DE776FD4138C&displaylang=en






Re: ClickOnce and Setup & Deployment Projects PROBLEM WHILE INSTALLING SETUP

PhilWilson

The way to debug MSI install issues is to create a log of the install. You do this with a command line install:

msiexec /i <path to msi file> /l*v <path to a text log file>

The log will report errors at the failure, and probably contain that error message text too.

If you have no installer classes or custom actions, about all that's left is an internal Dll used by the setup to check for the .NET framework.