Jay Buckman

I have a sequence of webpages (200 or so) with navigation and when I sequence through them, intermittently IE7 will simply display a blank white page and a "Done" message.  Pressing F5 will load the page properly.  This does not happen in IE6 and the frequency of white pages seemed to decrease as the IE7 betas progressed.   It happens if I am using IE7 on the webserver, from my desktop on the local network, or at a remote dial-up account.  If I put the HTML pages in simple ASPX wrappers, it never happens.  I've also loaded the content on several different servers and experience the same problems. 

Any ideas   I can post a link to a sample if that would help.

Jay



Re: Internet Explorer Web Development IE7 and White Screen

Jay Buckman

Some more info:

I've experimented by removing all links to CSS files and still have the problem.

If you right-click on the white screen and pick View | Source all of the HTML code is there.

It happens on both XP and Vista workstations.

The server OS is Windows Server 2003.





Re: Internet Explorer Web Development IE7 and White Screen

J Withnall

I have the exact same problem with a web app I'm building. Everything works perfectly in IE6 and Firefox.



Re: Internet Explorer Web Development IE7 and White Screen

Jay Buckman

I've managed to rule out (I think): XP/Vista, One Care, external CSS files, and a particular server. At the moment, I think referencing multiple .js files seems to cause or at least aggravate the problem. But not everyone with IE7 seems to experience the WSofD. Open the pages via the file system on the network doesn't cause WSofD. The symptoms can be very erratic which is making troubleshooting difficult.



Re: Internet Explorer Web Development IE7 and White Screen

EvilSpirit

I have the same problem and I think I've figured out what the problem realy is. In my page I include a java script file with <script src="sdc.js" type="text/javascript" />. When I change the line in <script src="sdc.js" type="text/javascript"></script> (with explicite empty body) the page works fine in IE7.
Maybe is there a problem the xml parser in IE7 With the "IE Developer Toolbar" I can see in the DOM tree that the complete body of the page is empty.




Re: Internet Explorer Web Development IE7 and White Screen

Jay Buckman

Mine are already in the <script ...></script> form and the pages load and function correctly most of the time. But I'll reload the developer toolbar and see if that gives me a clue. At the moment I'm suspecting a) too much included script or b) something in the way the functions are arranged in files, but I'm just guessing.



Re: Internet Explorer Web Development IE7 and White Screen

Jay Buckman

More Information:

I've loaded the IE Developer's Toolbar and when the white screen occurs, not all of the <SCRIPT> elements are loaded in the DOM and the <BODY> element is empty with the style set to a background-color of 0xffffff. It appears that IE7 just quit while processing the HTML document. The number of <SCRIPT> elements that are loaded varies - 4, 5, or 6 (there are 7 in the document).





Re: Internet Explorer Web Development IE7 and White Screen

Gerard K.

I have a similar problem. My page gets blank from time to time, totally random. The DOM explorer returns a blank <Body> tag.

I have several css and js scripts included. When I delete all js files it works fine, but even if I have one dummy js function i'm having the same problem again. If I'm using the extension .html, no trouble, if I'm using extension .php (wich i need) I get a regular blank page.

The page also has some complex nested table layout. I can't change that easily because it concerns a lot of intranet applications.

I think these problems are related:
http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=685241&SiteID=1
http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=867126&SiteID=1

So ... does MS already know about this problem




Re: Internet Explorer Web Development IE7 and White Screen

Jay Buckman

I've found what appears to be the source of my problem. I build the HTML files using a C#.NET application and I erroneously used Encoding.Unicode to write the files with a charset of UTF-8. But, the Unicode encoding is actually UTF-16.

Changing the encoding to ASCII and the charset to ISO-8569-1 or changing the encoding to UTF-8 and the charset to UTF-8 takes care of the problem. Changing the encoding to Unicode and the charset to UTF-16 still results in the intermittent, random white screens.





Re: Internet Explorer Web Development IE7 and White Screen

Jay Buckman

Followup: Of course the ASPX pages work - the default Encoding for the Response is UTF 8.



Re: Internet Explorer Web Development IE7 and White Screen

fasola

Perhaps, MS already know about this problem.
Our pages(Our page uses Japanese) had displayed blank.
But this hotfix resolved our problem.


http://support.microsoft.com/kb/933006/en-us