JohnCooperZone

hi,

I'm after some help. I've inherited a mini-site which contains a series of linked quicktime movie files (panorama images).

The site is using the old object & embed format, so has to be clicked on to be activated. I have tried changing the publishing method for the quicktime movie to the new 'AC_RunActiveContent.js' script in dreamweaver. This works, but only works, I cannot get it to work along side the existing QT movie code. can anyonr help

Original code:

<script language="javascript">
document.write('<OBJECT CLASSID="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" width="359" height="244" CODEBASE="
http://www.apple.com/qtactivex/qtplugin.cab"><PARAM name="SRC" VALUE="'+panoSrc+'"><PARAM name="AUTOPLAY" VALUE="true"><PARAM name="CONTROLLER" VALUE="true"><EMBED SRC="'+panoSrc+'" width="359" height="244" AUTOPLAY="true" CONTROLLER="true" PLUGINSPAGE="'">http://www.apple.com/quicktime/download/"></EMBED></OBJECT>');
</script>

New Code:

<script type="text/javascript">
AC_AX_RunContent( 'width','359','height','244','title','pano1','src','+panoshs+','autoplay','true','controller','true' ); //end AC code
</script><noscript><object width="359" height="259" title="pano1">
<PARAM name="SRC" VALUE="'+panoSrc+'">
<PARAM name="CONTROLLER" VALUE="true">
<embed src="'+panoSrc+'" width="359" height="259" AUTOPLAY="true" CONTROLLER="true"></embed>
</object>
</noscript>

The main problem i have is that the original code uses a variable for the movie, but when i do this with the new code it breaks. Is there somthing I'm missing