Al-Arabi

when i followed steps in lab D "Lab D: Use of SSO" Exercise1 and Exercise2 with application named "SSODemoLoginWebApp" every thing run ok, but when tryed to do the same with my application i found that username text box and password textbox not filled with username and password data, and nothing is happend. i tryed this with many applications i have, and when try to use my application url with the same name of  the application "SSODemoLoginWebApp" in sample Lab D it works fine,

i think there is one step is missed, please i want to know is there any missing steps

i appreciate your help  




Re: Customer Care Framework a problem with SSO Single Sign-On

Robert MacLean

Check the app.xml and appmapping.xml files in "C:\Program Files\Common Files\Enterprise Single Sign-On" are correctly configured. In particular the application name element in app.xml and externalapplication element in the appmapping.xml. Finally make sure you run the ssomanage commands to build the information into ESSO.

Remember you need to do this for every application and every agent.






Re: Customer Care Framework a problem with SSO Single Sign-On

Al-Arabi

yes i tryed this already before with command line and SSO Administration Console.

the problem already exist.

any another suggestions






Re: Customer Care Framework a problem with SSO Single Sign-On

Robert MacLean

Check the signer provider assembly it has some hard coding in it for demo apps. In the demo code this is: Microsoft.Ccf.Samples\Csr\Signer




Re: Customer Care Framework a problem with SSO Single Sign-On

Supriya A

I am facing the same problem. But not able to find the app.xml and appmapping.xml files in the specified folder. Please Help.



Re: Customer Care Framework a problem with SSO Single Sign-On

Supriya A

By foll. steps in Excercise 1, 2 the SSO doesn't work for an existing web App.

Also, according to Ex3, by adding an adapter to the app so as to have the credentials filled up for the user, I observed that the DoAction event is not getting fired for my web App, while it works properly for the existing SSOWinApp.

Do we need to inherit from ApplicationAdapter class no matter if the app. is Web or Windows or are there seperate adapters for both

Can you tell us how Web Applications can be coded for SSO in similar fashion

Please advice.





Re: Customer Care Framework a problem with SSO Single Sign-On

Robert MacLean

 Supriya A wrote:
I am facing the same problem. But not able to find the app.xml and appmapping.xml files in the specified folder. Please Help.

You must create those files manually from the examples provided.






Re: Customer Care Framework a problem with SSO Single Sign-On

Supriya A

OK.....done that. Modified the ApplicationSigner.cs as well, but the DoLogin() event is not getting called for my web app., while it does for SSODemoLoginWebApp. Also modified the config files in the AgentDesktop installation folder.

Am I missing anymore steps





Re: Customer Care Framework a problem with SSO Single Sign-On

Al-Arabi

ok..... Great, the problem solved and i wrote code to handle some issues SSO related and every thing is running now.

thanks