woutf

Hi,

I recently deleted a RAID array while the search index was stored on the drive (D:\). I had moved the index to the C:\ drive, but didn't reboot before deleting the array. This caused the search indexing service to break down. When I now try to start it I get the following error.

http://www.woutfunnekotter.nl/images/search_error.jpg

I've did some searching and it found threads with the same problem( http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=1346303&SiteID=1) , but the fixes I found don't work.

In 'C:\ProgramData\Microsoft\Search\Data\Config' schema.txt and garthrprm.txt are both present.(that was the solution offered in that thread)

I've included a screenshot of my registry, could that be of any help

http://www.woutfunnekotter.nl/images/search_registry.jpg


Re: Windows Desktop Search Help Vista Search indexer is broken after deleting database

woutf

Ok, after some rebooting and moving of files I've made a little improvement.

I deleted the search database again, and rebooted. The search service automaticly recreated the directory.
My registry now looks like this
http://www.woutfunnekotter.nl/images/search_reg_2.jpg

The error still remains though.
If I change the SetupCompletedSuccessfully DWORD to '1' the service will start, but the search config window will hang on 'Waiting to receive indexing status'





Re: Windows Desktop Search Help Vista Search indexer is broken after deleting database

Tonnni

I met the same problem,and hope a mvp help us.