DRoy99

I'm using Symbol XR 400 reader. While adding the device, it reports a problem as follows:

Failed to open connection to device
Unable to connect to the reader in 'Autonomous' Mode
Unable to enable polling
Commiting of configuration failed
at Symbol.RFID.AutonomousMode.AutonomousReader.EnablePolling()
at Symbol.RFID.SymbolRFIDReader.SetMode(String mode)
Details: Unable to connect to the reader in 'Autonomous' Mode
Unable to enable polling
Commiting of configuration failed
at Symbol.RFID.AutonomousMode.AutonomousReader.EnablePolling()
at Symbol.RFID.SymbolRFIDReader.SetMode(String mode)
Details: Unable to enable polling
Commiting of configuration failed

Details: Unable to commit configuration-failed with error code 63 - for 192.168.127.253

Fyi, there is no firewall in the server and the notification port is also not blocked by any other application (checked using netstat).

Any help is highly appreciated.

Thanks,



Re: BizTalk RFID Symbol XR400 Connectivity Issue

Peachi

What is the version of firmware in your XR400
also what is the version of the Symbol provider that you have

Has it worked at all with the view tags option under the device







Re: BizTalk RFID Symbol XR400 Connectivity Issue

Anush Kumar - MSFT

Hi Roy:

If you could follow up with me offline, I can send you a document that is a detailed guide for Symbol readers (not sure how to post it here Smile)

Have also notified the Symbol folks -> if you could send out the logs (provider and service logs) that would be helpful as well to troubelshoot

Cheers!

/a






Re: BizTalk RFID Symbol XR400 Connectivity Issue

DRoy99

The error message that comes up now is 'Failed to open connection to device
Unable to connect to Get Reader Antenna Information'. But I can see in the log that it's able to login to the reader. There are only 2 antennas connected to the reader (not 4); I'm not sure if that's cause of this problem.

Versions are as follows:

Current Firmware Version: 5.0.4
RxDSP Boot Version: 2.7.0
RxDSP Version: 5.0.0
FPGA Version: 5.5.0
Provider Version : 1.0.13.3

Thanks,





Re: BizTalk RFID Symbol XR400 Connectivity Issue

Krish Gopalan - MSFT

This has been resolved. The symbol provider does not support AR400 model, the mode that Roy is using



Re: BizTalk RFID Symbol XR400 Connectivity Issue

sbranch

I have been having using the symbol firmware version 2.4.2 and the reader seems to quit responding to the framework after about 2 days. What is the latest firmware that the reader should have to work with the RFID framework.