BMarr

When I try to connect to the "Customer Orders Manager" I get the following error

The Orders Web Service "https://cs2007/OrdersWebService/OrdersWebService.asmx" is currently unavailable. The web service might be experiencing technical difficulties, or you may need to adjust your connections settings.

I have all my user roles mapped properly through SQL Server 2005 as outlined in the installation manual for the Commerce Server Starter Site.

When I try to "refresh the site Catalog" in the Catalog Manager I get this error:

An exception occurred in the CatalogWebService Web Service Exception details follow:

Microsoft.CommerceServer.CacheRefreshFailedException: One or more errors occured while refreshing the cache 'CatalogCache'

of the site 'Starter Site':

The server 'CS2007' of the application StaterSite returned HTTP status code 401 (Unauthorized). The cache refresh URL used was http://cs2007/StarterSite/SiteCacheRefresh.axd CacheToRefresh=CatalogCache

The server 'CS2007' of the application OrdersWebService returned HTTP status code 503 (Service Unavailable). The cache refresh URL used was http://cs2007/OrdersWebService/SiteCacheRefresh.axd CacheToRefresh=CatalogCache

Can anyone help me



Re: Commerce Server 2007 Orders Web Service

enizin

You may have an issue with your site certificate. Try pasting the URL into your browser. That should help you diagnose the issue.

Ian





Re: Commerce Server 2007 Orders Web Service

BMarr

When I paste the following URL into my web browser I get "Service Unavailable"

https://cs2007/OrdersWebService/OrdersWebService.asmx

When I paste the following URLs into my web browser I get "Internet Explorer cannot display the webpage"

http://cs2007/StarterSite/SiteCacheRefresh.axd CacheToRefresh=CatalogCache

http://cs2007/OrdersWebService/SiteCacheRefresh.axd CacheToRefresh=CatalogCache

Needless to say neither helped me diagnose the issue any further.

Please note that Commerce Server and the Starter Site are both installed on a virtual machine running Windows Server 2003





Re: Commerce Server 2007 Orders Web Service

Max Akbar

So you have two issues and should really create two posts.

Issue 1:

Have you installed an SSL certificate What happens if you hit the url using IE

Issue 2:

Under the web.config of the site you will need to add the app pool of the Catalog Web Service to refresh the cache.

-Max






Re: Commerce Server 2007 Orders Web Service

SPWS

For the Orders web service not being available you will need to verify the following:

> The accout that the app pool the Orders web service is running in has appropriate permissions to the SQL database, is a memeber of the IIS_WPG group

> That the user account you are using when starting the Customer and Orders Manager is a member of the Profile Administrators group in the authorization policy file

You can refer to the starter site install guide on permission settings.

For the 404.1 error take a look at the following articles.

Article #896861

You receive error 401.1 when you browse a Web site that uses Integrated Authentication and is hosted on IIS 5.1 or IIS 6
http://support.microsoft.com/default.aspx scid=kb;EN-US;896861

Article #931290

You receive error messages when you update the catalog cache or the profile cache in Commerce Server 2007

http://support.microsoft.com/kb/931290






Re: Commerce Server 2007 Orders Web Service

Max Akbar

Let's fix one issue at a time:

Issue 1

If you got "Service Unavailable" this means that you have setup your App Pool identity incorrectly.
1. Make sure that your account is a member of IIS_WPG
2. Make sure that the user has the correct access to C:\windows\Temp folder (Read and Write permissions)
3. Make sure that the user has the correct access to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files (Read and Write permissions)

Once this issue is fixed let us know and we will look into Issue 2.

Good luck,

-Max







Re: Commerce Server 2007 Orders Web Service

BMarr

Ok, we have made sure that our account is a member of IIS_WPG and has correct access to C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files and C:\windows\Temp (read and write). However, after verifying these things we still get "Service Unavailable" when we try to access the Orders Web Service. Any further advice





Re: Commerce Server 2007 Orders Web Service

Max Akbar

This is probably a dumb question but after made the verifications did you start the app pool If not please start the application pool and try again. If you run into the same issues here is what I would try.


Run filemon with the w3wp.exe filter and see if you are having any issues with any of the files it is trying to open. Next try hitting the url without the ssl http://cs2007/OrdersWebService/OrdersWebService.asmx. Look in the event log and see if there any errors if so post them here.

Good luck,

-Max






Re: Commerce Server 2007 Orders Web Service

BMarr

Max.

After restarting the app pool we still have the same issue. We solved part of Issue 2 and now we only need the orders web service working to have both issues solved.

After hittting the url without the ssl we get the following errors:

Error 1:

The worker process failed to initialize the http.sys communication or the w3svc communication layer and therefore
could not be started. The data field contains the error number.

0000: 57 00 07 80 w..[]

Error 2:

A failure was encountered while launching the process serving application pool 'OrdersWebSvcAppPool' The application Pool has been disabled.

Any assistance with this is greatly appreciated.





Re: Commerce Server 2007 Orders Web Service

Max Akbar

Let's try a quick thing to verify that it's the service account. Assign the app pool of the web service the domain admin account then try hitting the web service if it all works then you have an invalid web service account.

-Max






Re: Commerce Server 2007 Orders Web Service

BMarr

After assigning the app pool of the web service the domain admin account we were still unable to access the web service. We are still getting the same error "Service Unavailable" when we run the url to the web service.



Re: Commerce Server 2007 Orders Web Service

BMarr

Ok, i went over and tried assigned the domain admin account to the app pool of the web service and it works now. I guess i must of had the admin password incorrect. Should we leave it like that and if not, what are the next steps that should be taken





Re: Commerce Server 2007 Orders Web Service

enizin

This is probably another dumb question but have you checked the application event log





Re: Commerce Server 2007 Orders Web Service

BMarr

We actually checked that about 5 posts back and posted the errors that were in teh event log thanks. As for the problem we have it working now. The Orders Web Service account was set up for "change password at next log on" we changed it to "password never expires" and it all works fine now. Thanks for all your help.