Ernst Kuschke

Hi,

I am trying to install CS2007 onto a Windows 2003 Server box on which I have removed the "Default" IIS website. The CS Configuration wizard refuses to do anything because of the absence of the "Default Web Site".

Is there any way that I could work around this issue and get CS running



Re: Commerce Server 2007 Default Web Site missing

Ernst Kuschke

Ok, I managed to restore the Default Web Site, but the Configuration Wizard still fails. I am attaching the last part of my Configuration Log:

[15:25:49 INFO] Installing components from 'C:\Program Files\Microsoft Commerce Server 2007\pipeline.dll' into COM+ Application 'Commerce Server Orders'
[15:25:49 ERROR] CSConfig failed during configuration of feature Commerce Server Pipelines (Feature.MS.CS.Core).
[15:25:49 ERROR] Exception occured during feature configuration: Microsoft.CommerceServer.Internal.Config.ConfigurationException: Errors occurred accessing one or more objects - the ErrorInfo collection may have more detail (Exception from HRESULT: 0x80110401) ---> System.Runtime.InteropServices.COMException (0x80110401): Errors occurred accessing one or more objects - the ErrorInfo collection may have more detail (Exception from HRESULT: 0x80110401)
at comadminlib.COMAdminCatalogClass.InstallMultipleComponents(String bstrApplIDOrName, Object[]& ppsaVarFileNames, Object[]& ppsaVarCLSIDs)
at Microsoft.CommerceServer.Internal.Config.NativeComPlusApplication.InstallComponentsIntoApplication(String applicationName, Guid msiComponentGuid, Guid[] clsIds)
--- End of inner exception stack trace ---
at Microsoft.CommerceServer.Internal.Config.NativeComPlusApplication.InstallComponentsIntoApplication(String applicationName, Guid msiComponentGuid, Guid[] clsIds)
at Microsoft.CommerceServer.Internal.Config.PipelinesConfig.ConfigurePipelinesForBitness(String applicationName, Guid componentGuid)
at Microsoft.CommerceServer.Internal.Config.PipelinesConfig.Configure()
at Microsoft.CommerceServer.Internal.Config.ConfigurationDriver.ConfigureHelper(List`1 orderedListOfFeatures).
[15:25:49 INFO] Exception was non-fatal. Beginning rollback.
[15:30:30 INFO] Beginning unconfiguration of feature Commerce Server Pipelines (Feature.MS.CS.Core).
[15:30:30 INFO] Deleting existing COM+ Application 'Commerce Server Orders'
[15:30:31 INFO] Completed unconfiguration of feature Commerce Server Pipelines (Feature.MS.CS.Core).
[15:30:31 INFO] Beginning unconfiguration of feature Administration Database (Feature.MS.CS.Admin).
[15:30:31 INFO] Deleting existing COM+ Application 'Commerce Server Config'
[15:30:31 INFO] Completed unconfiguration of feature Administration Database (Feature.MS.CS.Admin).

Any ideas





Re: Commerce Server 2007 Default Web Site missing

Ernst Kuschke

So, for what it's worth, I fixed this issue by unregistering the pipeline.dll from a previously installed version Commerce Server (2000).

unregsvr32 /u <path>\pipeline.dll