JohnLi

I download it from http://download.microsoft.com/download/B/A/D/BADA8219-9761-498D-85B4-4565C28F4DB8/crt/cpuid.zip.exe

I found that in "cpuid.c", dynamic help shows "No links are available for the current selection", and in "cpuid.h" and "test.cpp" dynamic help is okey.

And I can also build and run the program.

But why Dynamic help doesn't work in cpuid.c Need help.



Re: Visual C++ Express Edition Dynamic help doesn't work in cpuid.c, but works in cpuid.h and test.cpp???

nobugz

To build that sample, you need to change the current configuration. Build + Configuration Manager, change Platform from Titanium to Win32. You can't expect dynamic help to give you any info on cpuid.c; it is filled with assembly code and other low-level stuff. If you really want to find out what it does, you'll have to read an Intel or AMD processor manual.





Re: Visual C++ Express Edition Dynamic help doesn't work in cpuid.c, but works in cpuid.h and test.cpp???

JohnLi

Thank nobugz for the answer, but my question is that I can build and run that program, just the Dynamic help doesn't work in cpuid.c, and I know help links for those assembly codes, but the thing is even for those very basic items like "int" there are no hlep links as well, that is the Dynamic help doesn't work for "cpuid.c" at all.

So I guess perhaps it doesn't support for ".c" files, then I removed "cpuid.c", and add a new file "t.cpp", and copy all in "cpuid.c" and pasted them in "t.cpp". This time, Dynamic help works well. And it can also build and run as well.

So perhaps this version Dynamic help doesn't support .c files





Re: Visual C++ Express Edition Dynamic help doesn't work in cpuid.c, but works in cpuid.h and test.cpp???

nobugz

Yes, it acts a bit flaky; I'm getting no help on int, char, return, case. Others work fine though. You might want to file a bug report a Product Feedback.





Re: Visual C++ Express Edition Dynamic help doesn't work in cpuid.c, but works in cpuid.h and test.cpp???

JohnLi

Thanks, nobugz.

I tried that link, it's too slow and gave out a error message when I tried to register. If it's possible, can you report that bug