yanivsag

Hi,

I've recently upgraded to VS2005 from vc6 and my greatest problem is this:
I'm debugging my app (a very large one in terms of modules and lines) and if i try to edit the code when a breakpoint is hit (in order to try edit&continue) visual studio hangs and i keep getting the "visual studio delay notification" in my task bar.

Has anyone came up with this matter
Any suggestions

thanks


Re: Visual C++ General Debugger hangs when editing code

yanivsag

I forgot to mention that i have SP1 installed.
w2k sp4 (although it happened to other people here with windows XP and the same configuration)
1 GB of memory
3 Ghz P4 processor





Re: Visual C++ General Debugger hangs when editing code

Ramkrishna Pawar

Have you tried rebuilding all the modules

You should try this with new Visual Studio 2008 (beta)






Re: Visual C++ General Debugger hangs when editing code

yanivsag

Yes, i've tried rebuilding everything.
didn't work




Re: Visual C++ General Debugger hangs when editing code

Ramkrishna Pawar

It could be problem with Visual Studio, but I am not sure..




Re: Visual C++ General Debugger hangs when editing code

yanivsag

You think

It happens to everybody else on the project. and we're not running the same image,
do you think 1gb more of RAM would fix this issue
maybe the VS2005 debugger has a limit of the size of project it can handle with only 1 GB of ram (This issue doesn't occur on small projects)




Re: Visual C++ General Debugger hangs when editing code

Ramkrishna Pawar

yanivsag wrote:
You think

It happens to everybody else on the project. and we're not running the same image,
do you think 1gb more of RAM would fix this issue
maybe the VS2005 debugger has a limit of the size of project it can handle with only 1 GB of ram (This issue doesn't occur on small projects)

I dont think it is a problem with RAM, however you can try with 1 GB.

Does that hang remain forever Or does it only take too much time to come out of it






Re: Visual C++ General Debugger hangs when editing code

yanivsag

Ramkrishna Pawar wrote:


I dont think it is a problem with RAM, however you can try with 1 GB.

Does that hang remain forever Or does it only take too much time to come out of it



It doesn't remain forever but takes about 5 minutes until i can continue debugging.
Maybe there's some background process in VS that occurs when i start editing during the break
b.t.w,
I didn't mention it before - Thanks for trying to help.





Re: Visual C++ General Debugger hangs when editing code

Ramkrishna Pawar

Well, in this case adding more RAM might help....




Re: Visual C++ General Debugger hangs when editing code

yanivsag

We'll know in few days...
In the mean time - we stopped using Edit & continue
during debug




Re: Visual C++ General Debugger hangs when editing code

codevis

Have you tried turning off Intellisense That's been the source of a number of bizarre crashes and long delays I've endured ever since upgrading from VS 6.0. Wishing I could go back and still use recent SDKs Sad





Re: Visual C++ General Debugger hangs when editing code

kkppmm

Norton Antivirus was causing some fits for me. Did you look in your antivirus detailed reports to see if something was getting blocked



Re: Visual C++ General Debugger hangs when editing code

yanivsag

yes, I looked in NAV's event log and even turned it off on one of the sessions but it didn't help.
thanks for your reply




Re: Visual C++ General Debugger hangs when editing code

yanivsag

codevis wrote:
Have you tried turning off Intellisense That's been the source of a number of bizarre crashes and long delays I've endured ever since upgrading from VS 6.0. Wishing I could go back and still use recent SDKs



do you mean turning it off completely, or only before starting a debug session





Re: Visual C++ General Debugger hangs when editing code

yanivsag

codevis wrote:
Have you tried turning off Intellisense That's been the source of a number of bizarre crashes and long delays I've endured ever since upgrading from VS 6.0. Wishing I could go back and still use recent SDKs


well,
i've tried turning intellisense off. didn't help.
thanks