Jeff_R

Hi all,

I'm working with a team using VSTO 2005 to automate 'smart documents' and we are seeing an issue when a user updates a Text field (XML element) and we go to update the page (pushing through the WML transform for the doc) the carriage returns, fonts etc are lost.

How can we get these formatting elements to persist when going through a transform

Thanks!

Jeff




Re: Visual Studio Tools for Office Loosing formatting when applying WML Transofrms to text elements

Cindy Meister

Hi Jeff

Can you be more specific about what kind of "textfield" you're trying to deal with I think I understand that the user does some kind of formatted editing (where ), and that the formatting is lost when you transform something (what, more exactly ) into WordProcessingML and pass it directly into the (opened ) Word document. But those pesky details telling exactly what's going on aren't clear....






Re: Visual Studio Tools for Office Loosing formatting when applying WML Transofrms to text elements

Jeff_R

We have a smart document that is defined by an XML Schema. The user places the cursor in various areas of the document and the task pane will update with controls specific for that region of the doc. When they enter text into the text bot or free form text areas on the doc and something else is changed in the task pane the update is done by reading the elements (as XML) from the doc and updated info from the task pane and it's all reapplied to the schema and passed through a transform to update the doc. At that point formatting, carriage returns, fonts etc are lost.

Hope that helps!

Thanks!

Jeff






Re: Visual Studio Tools for Office Loosing formatting when applying WML Transofrms to text elements

Jeff_R

When they enter text into the text bot or free form text areas on the doc...

When they enter text into the text boX or... Smile