davidMartin

Hi,

In my addin ( Outlook 2007 and VSTO 2005 SE), I created different ribbon customizations that I load at runtime.
I create the xml at the "GetCustomUI" call.
When I debug in VS, everything works great but when I deploy it, my addin is working well expect my ribbon customizations...
( my addin is noted as "activate" in the complement menu )

I check the "Show add-in user interface errors" but any message appear...

what can be wrong in my addin code

Thanks,

David


Re: Visual Studio Tools for Office Ribbon not loaded

davidMartin


It's look like the function:

" protected override object RequestService(Guid serviceGuid)"

is called when I'm debugging with VS2005 but not called when deployed on a target machine...

Is that possible

Thanks for any help...

david




Re: Visual Studio Tools for Office Ribbon not loaded

davidMartin


Hi,

Does anyone can explain me the "RequestService" call mechanism
Does a special registration is necessary
How can it be possible my ribbon addin works in my dev environment but not on deployed computers

I really need my ribbon work...

David




Re: Visual Studio Tools for Office Ribbon not loaded

davidMartin

I found this post about "requestService" :
http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=756181&SiteID=1
It¡¯s talking about a registration needed but it's for the Form Region. Is there the same things for the ribbon

Moreover I read those 3 interesting articles:
http://blogs.msdn.com/andreww/archive/2006/04/04/568607.aspx
http://blogs.msdn.com/andreww/archive/2006/12/23/low-level-support-for-icustomtaskpaneconsumer-iribbonextensibility-formregionstartup-etc.aspx
http://blogs.msdn.com/andreww/archive/2007/05/30/office-2007-new-extensibility-interfaces.aspx

but I cannot understand why my ribbon does not appear in deployment situation....

David




Re: Visual Studio Tools for Office Ribbon not loaded

davidMartin


I found the solution to my problem!

DO NOT PUT registry keys under HKLM...




Re: Visual Studio Tools for Office Ribbon not loaded

Natarajan Krishnan

Hi David,

I am also facing the same issue. Could you just post what exactly you did to fix the issue

Thanks,






Re: Visual Studio Tools for Office Ribbon not loaded

Andrew Cherry [MSFT]

Hi Natarajan -

David had been registering the add-in on the destination machines in the HKEY_LOCAL_MACHINE registry hive.

VSTO solutions for Office 2007 (the only location for Ribbon customizations) are only supported in the HKEY_CURRENT_USER registry hive.

Registering the add-in for each user will result in the add-in being run, and the Ribbon customization being loaded. No additional registration aside from that to load the add-in is necessary for Ribbon customization.

Andrew






Re: Visual Studio Tools for Office Ribbon not loaded

Ahmed Alaoui

Hi all,

I have the same issue, but i'm not using HKLM, can you help me to find the issue plz

Thanks
Ahmed