KenMcCormack

Hi there

I'm deplying a VSTO SE Word Add In. I've been running alongside the walkthrough / sample project at

Deploying Visual Studio 2005 Tools for Office Second Edition Solutions Using Windows Installer (Part 1 of 2)

The only slight variation from the walkthrough is that I've added a GAC node to the File System of the setup program, to install the EntLib 3.1 signed assemblies.

Issues are as follows:

- After install there's no add in loaded

- It's not visible in the disabled add-ins list in Word

- The registry entry at HKCU\Software\Microsoft\Office\Word\AddIns does not list my add in

Looks like my add-in is not being installed into the registry

FYI

- I run my install from a network folder

- This installs without error - is logged in the event log as completed successfully

- The dll's are installed correctly under C:\Program Files etc

- The EntLib assemblies are there under C:\Windows\assembly

- Install all users is true, I'm installing as the machine's local administrator

Any ideas where I should be looking next

Thanks in advance

Ken

ps. Just spotted this post on Misha Shneerson's blog which might well answer this for me (i.e. you can't install an add in for ALLUSERS - only the current user... )

http://blogs.msdn.com/mshneer/archive/2007/09/04/deploying-your-vsto-add-in-to-all-users-part-i.aspx

Does the walkthrough need to shout this out in big red letters Surely most people are deploying to an SOE



Re: Visual Studio Tools for Office Add-In key missing from registry - troubleshooting advice needed VSTO SE add in install

Misha Shneerson - MSFT

Ken, as you have probably already figured out there is also part II installment for All Users deployment Smile

After hearing so much feedback about about All Users we have decided to do something about it and the descibed mechanism came up (whichrelies on an internal Office feature). This information is pretty new to ourselves due to the undocumented nature of this mechanism so that is why it has not been yet incorporated into existing MSDN articles. Darryn Lavery is preparing a separate MSDN article that will address All Users scenarios in a very detailed walkthrough, meanwhile you can use the part 2 of my blog post as a general guidance for your setup.






Re: Visual Studio Tools for Office Add-In key missing from registry - troubleshooting advice needed VSTO SE add in install

KenMcCormack

Hi Misha

No luck so far... when a user logs in I think we need to insert the key into the registry with a script. The user won't ever run the installer themselves, only a system admin who prepares the image.

I added the registry key manually - to HKCU\Software\Microsoft\Office\Word\Addins - The LoadBehavior value is being updated to 2 when Word is opened - I think this means the assembly has an issue elsewhere

http://forums.microsoft.com/MSDN/ShowPost.aspx PostID=161726&SiteID=1

Ken





Re: Visual Studio Tools for Office Add-In key missing from registry - troubleshooting advice needed VSTO SE add in install

Misha Shneerson - MSFT

Try setting VSTO_SUPPRESSDISPLAYALERTS=1, change LoadBehavior to 3 and restart Word.

See this link for debugging failing add-ins.