kkarre

Hi all,

I'm backing down to make sure I find a way to deliver to my customer the next few days:

I have developed an Excel template with some .NET code behind using VSTO 2005.
Not the SE, the first version.
My solution uses another .NET assembly (helper.dll) besides the code assembly data.dll "behind" the document (data.xlt).

I added a setup project to the solution. Which isn't enough of course.
I created to separate install classes, one to install a policy code group thats gives Full trust to data.dll and one to bind the data.dll path to the data.xlt document (via ServerDocument). I added the custom Action to Install the CustomSetup.dll with these installer classes.

Now to my questions:
Are there any walkthroughs to this kind of work The links at
PLEASE READ NEXT: VSTO 2005 Resource List
doesn't work.

Should I have another install object and collect the both custom installers in that installer's installers property

Do I need the same kind of custom installers for the helper.dll

Could anyone please help/advice

Best regards,
/k



Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment

kkarre

I've searched the whole community for windows installer walkthroughs, the only tips I can find are:

http://msdn.microsoft.com/office/default.aspx pull=/library/en-s/odc_vsto2005_ta/html/OfficeVSTOWindowsInstallerOverview.asp and http://msdn.microsoft.com/office/default.aspx pull=/library/en-us/odc_vsto2005_ta/html/OfficeVSTOWindowsInstallerWalkthrough.asp.

They have both moved, but the stated adress isn't valid.

Urgh - H - E - E - e - l ... p ...

please !





Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment


Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment

kkarre

Hello again,

Thanks for the help above. Unfotunately it doesn't resolve my issue.
The walkthrough falls short in two ways:
1.My customer's contact person does not have administrative rights so I must use Group Policy to enable the installation.
2.I do have extra class librarys, so I need to address that.

I've tried for several days now but something must be missing.

I doesn't help much if I reduce the code to a test without extra dll:s - I still need to give the installer sufficient permissions (which with vsto is always Full trust).

Anyone, please
/kk





Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment

kkarre

OK,
a little closer to the goal:
The setup works on a machine with VSTO runtime, but can't install the runtime...
A new installer class or can I reuse the existing

The primary problem seems to be that my development environment doesn't match the one in the walkthrough.
Quote from Deploying Visual Studio 2005 Tools for Office Solutions Using Windows Installer: Walkthroughs (Part 2 of 2):
Adding the Prerequisites to the Setup Project
This step assumes you have prepared the development environment.

What's the preparing I haven't done My prereq dialog doesn't have the alternatives vstor & Office2003PIA...


Am I really the only one with these problems




Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment

Sarge1

Look in the "Detectingh and Installing Prerequistes" section of the first article. (http://msdn2.microsoft.com/en-us/library/aa537173(office.11).aspx) It references another article on the bootstrapper (http://msdn.microsoft.com/msdnmag/issues/04/10/bootstrapper/default.aspx)

That should help.





Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment

kkarre

I can't find the section "Detecting and Installing Prerequistes" in either article.

I've tried to install vstor.exe and OfficePIA.exe but they don't add the kind of folder with product.xml and package.xml under sdk\2.0\Bootstrapper\Packages that documentation states.

So... what am I not understanding...





Re: Visual Studio Tools for Office Mo A more thorough question on VSTO deployment

kkarre

I can answer this too myself...

The most blame should be mine...
I printed the walkthroughs 2 pages per paper and missed the part about manually copying the packages from the sample files to bootstrapper.
With the correct package folders under bootstraper\Packages they DO turn up in the prerequesities dialog! So, I managed at last! Thanks for the inputs!

/k