SSG3141592


I've got a package which reads a text file into a table and updates another. I set up configurations so that I could import it into the SSIS store on both my dev and live servers. Now, I'm getting this error. I tried removing the configs and am still getting it.

I've been through each step and everything looks okay. Does anyone have any idea (a) what's wrong, (b) how to localise the error or (c) get any additional information Or do I just have to recreate the package from scratch

TITLE: Package Validation Error
------------------------------

Package Validation Error

------------------------------
ADDITIONAL INFORMATION:

Error at PartnerLinkFlatFileImporter: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not found.

Error at PartnerLinkFlatFileImporter [Log provider "SSIS log provider for SQL Server"]: The connection manager "" is not found. A component failed to find the connection manager in the Connections collection.

(Microsoft.DataTransformationServices.VsIntegration)

------------------------------
BUTTONS:

OK
------------------------------




Re: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not f

Phil Brammer


Did you build this package, or did a wizard such as the import/export wizard

Also, if you open up the .dtsx file in Notepad (or your favorite text editor) you can search for:

"DTS:ConnectionManager"

When you find that section, look for the DTS: Property titled, "ObjectName". Do you have something listed there, or is it blank Keep searching through all of your connection managers if you have more than one. See if there is one listed there with an empty ObjectName property.






Re: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not f

SSG31415926

Thanks for your help. It turned out that I when I added a SQL Server logging provider (to help solve another problem) I didn't add the connection string name to the Configuration column. Oh well! Another afternoon to learn another simple thing!




Re: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not f

omegarazor

Thanks!! I had exactly the same sit. Your solution caused me to recheck this config setting and it was right on track.






Re: The connection "" is not found. This error is thrown by Connections collection when the specific connection element is not f

prashant

thanks Phil!!