Peter Rex

Hi friends

When i try to open my EventViewer in Vista it gives a message like

"Event log service is unavailable. Verify the service is running"

Then i tried to start the Windows Event Log service from the windows services but it is giving another error message.

"Windows could not start the Windows event log service on Local Computer.

Error 4201: The instance name passed was not recoganized as valid by a WMI data provider."



Re: UI Development for Windows Vista Event Viewer Service problem

Hellboy

I'm having the same problem. Even tried to reset the WMI, still same problem occurs.

I'm also having problem with trying to start Generate Health Report, error was "Unknown Interface"

Can anyone hellllpppppp!! Pls!!!!!!






Re: UI Development for Windows Vista Event Viewer Service problem

cridel

Hi all,

I have same problem when i try to start Event Log service.

No response from Microsoft corporation, it seems to be a major bug in Vista installation, but no addtionals information.

Wait and see...may be a service pack should fix this critical bug for other services or for applications.

Christophe





Re: UI Development for Windows Vista Event Viewer Service problem

Tbird650

Same problem here too......... and problems with windows search ............and problems with "move" or "rename" file (hangs).

Roll on service pack update!





Re: UI Development for Windows Vista Event Viewer Service problem

phialv

Hi Peter,

I have the same problem with the Vista EventViewer. Diskeeper won't work either, but I don't know if these are related.

Good luck,

Phil

[Lenovo TP-T60: 2xCPU T7200, 2GHz, 1.5 GB RAM; Vista 32-bit Business, build 6.0.6000; No other programs running]






Re: UI Development for Windows Vista Event Viewer Service problem

Tbird650

Hi Phil & other interested parties

Some of the other clues:

When I updated from XP, I used the files & settings transfer wizard.....after which time the keyboard didnt work properly. Thats fixed now though. Still I wonder if settings from Xp somehow clash

Also had installed Nero Essentials.7......well I only noticed problems after that. Co-incidence maybe Uninstalled now and no fix yet.

Then there's the bios update question.....will that improve reliability, etc. It's a bit daunting and the Asus website appears somewhat ambiguous as to which update is fitting.

Post back any thoughts. Thanks.

Peter





Re: UI Development for Windows Vista Event Viewer Service problem

are bee en zed

I have the same problem, also after a Nero install then uninstall.



Re: UI Development for Windows Vista Event Viewer Service problem

alvox

The same problem here. Cant start some services.
Any response from MS ! Is it bug or something broken in my installation




Re: UI Development for Windows Vista Event Viewer Service problem

Tbird650

Have fixed the copy/ move file problem by disabling indexing and windows search in services. Also search runs ok now too.

The event viewer is as yet unsolved.

.....error message is: Unhandled excetion in managed code snap-in.

Other article has more info but no fix for me:

http://forums.microsoft.com/TechNet/ShowPost.aspx PostID=970546&SiteID=17





Re: UI Development for Windows Vista Event Viewer Service problem

tburr@collegenet.com

All Vista machines at our company are having this issue. Anyone find a fix yet




Re: UI Development for Windows Vista Event Viewer Service problem

MetroVavin

I found this tip on another forum.
Run regedit.
Go to computer\HKLM\system\currentcontrolset\services\eventlog\
run through all subkeys looking for path names and make sure the folders exist and have write privileges.
For example, the log file may be stored in:
%SystemRoot%\system32\winevt\Logs\Application.evtx
If the folder is not there or is not write enabled, the service may fail to start.
You would get an error "file path not found" or "file access denied" or something like that.





Re: UI Development for Windows Vista Event Viewer Service problem

phialv

Hi Peter,

The history of my system is similar to yours in certain respects, but I don't know if there's a causal relationship between the changes and our Event Viewer problem. These similarities/differences are:

- Files & Settings Transfer Wizard - I used this, plus the System Migration Assistant, to move settings and files from one laptop to another. The former had Win XP Pro SP2 installed and the latter Vista 32 Business. My experience with this process was that there appeared to be a massive shuttling/shuffling of many files from one system to the other and it inspired no confidence in me that everything happened as it should.

- Keyboard Problems - I've been having persistent problems with an external USB keyboard becoming inactive, but that seems to occur only when I connect the keyboard via a USB hub, not directly to the laptop.

- Nero Essentials - I too installed and uninstalled this, and there appears to be vestiges of Nero fiddling around. For instance, it still appears as an entry (which I've disabled) in System Services.

Office 2007 - I also uninstalled this suite, which was pre-installed as a trial version on my laptop, in favor of Office 2003, and there are still pieces of Office 12 all over the place.

The difficulty with trying to locate the problem by researching histories is that there were so many widespread system changes occuring at different times that it's impossible to identify those that might be responsible. Nonetheless, I hope that this helps.

Good luck,

Phil






Re: UI Development for Windows Vista Event Viewer Service problem

Tbird650

My event viewer is working again. This was just after I fixed the problem of not being able to un-install I-tunes & Adobe8.

The problem there was with "permissions" with some windows registry keys......... (of course it could be co-incidence)

I seem to remember, the event viewer error came up with a number.....this could refer to the key that has incorrect permission settings. Hope this helps....good luck.





Re: UI Development for Windows Vista Event Viewer Service problem

Lone Kawboy

Has anyone came up with a "clean" solution to this problem





Re: UI Development for Windows Vista Event Viewer Service problem

LukeFoley

Hey,

I had this exact problem. Not sure what triggered it but I only noticed Event Log service wasn't working after installing Norton Ghost v12.

To resolve this problem I modified the ACL to the HKEY_LOCAL_MACHINE registry key and the ACL for %windir%\system32\winevt

To change the ACL's for these, i recommend using SubinACL (download from: http://www.microsoft.com/downloads/details.aspx FamilyID=E8BA3E56-D8FE-4A91-93CF-ED6985E3927B)

Install SubinACL and run a Command Prompt as an Administrator and execute the following commands:

subinacl /subregkeys HKEY_LOCAL_MACHINE /grant=administrators=f /grant=SYSTEM=f

subinacl /subdirectories %windir%\system32\winevt /grant=administators=f /grant=SYSTEM=f

I hope this helps you with this problem. Let me know if you can.

Thanks,

Luke