snail52071

I have been using graphedit to connect to my remote graphs in the past and everything worked fine. Somewhere along the way this stopped working. I don't know exactly when. Remote graphs show up in the remote graphs list, but when I select one nothing is displayed. I have tried this with my apps and some samples that I know should work because they worked in the past. Any pointers would be appreciatted.

Steve



Re: DirectShow Development Graphedit doesn't show remote graph

cheesetarmac

If you're using Vista, one thing you might want to consider is whether you're executing GraphEdit as an Administrator eg Run as.




Re: DirectShow Development Graphedit doesn't show remote graph

Geraint Davies

the proxy interface objects that used to be in quartz.dll (and thus part of the system) have been removed in Vista and are now in proppage.dll (and thus part of the SDK). Get the Windows SDK for Vista and regsvr32 proppage.dll.

G





Re: DirectShow Development Graphedit doesn't show remote graph

snail52071

I am using WIN XP SP 2 32 bit. I originally installed Direct X 9.0 SDK. At some point I installed the Windows SDK for Vista. I have tried unregistering proppage.dll and registering the proppage.dll from direct x 9 and running graphedit from direct x 9 - doesn't work. I have tried registering the proppage.dll from the windows sdk and running graphedit from windows sdk and that doesn't work either.



Re: DirectShow Development Graphedit doesn't show remote graph

Geraint Davies

Did you try re-registering quartz.dll



Re: DirectShow Development Graphedit doesn't show remote graph

snail52071

I uninstalled the windows sdk for vista, unregistered the proppage.dll, and quartz.dll. Then copied them from directx directory into system32 and re-registered them. That fixed the problem.